Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Условие на наличие определенной надписи в определенной группе строк
 
Уважаемые знатоки, внимание, вопрос!
Есть таблица (см. приложение), содержащая номер документа, фамилии людей, которые должны подписать этот документ и 3-ий столбец (необходимо заполнить с помощью формулы). В 3-ем столбце нужно напротив номера документа проставить 1, если в подписантах есть Васечкин, и 0, если в подписантах Васечкина нет.

Как это должно выглядеть, показано в таблице. Можно ли как-то заполнить с помощью формул Excel этот столбец?
 
в С2 можно ввести такую формулу массива:
Код
{=ЕСЛИ(СУММ(($A$2:$A$9=A9)*($B$2:$B$9="Васечкин"))>=1;1;0)}
и растянуть вниз.
Кому решение нужно - тот пример и рисует.
 
Пытливый,Спасибо! Все работает.
 
для 2007 и выше
Код
=СЧЁТЕСЛИМН($B$2:$B$9;"Васечкин";$A$2:$A$9;A2)

для данного примера достаточно и так
Код
=СУММПРОИЗВ(($A$2:$A$9=A2)*($B$2:$B$9="Васечкин"))
Изменено: V - 16 Апр 2015 11:16:33
Страницы: 1
Читают тему (гостей: 1)