Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Выбор значения из группы
 
Здравствуйте! Есть сложность с составлением правильной формулы.

Нужно что бы анализировались столбцы в группе и в желтые ячейки выводился результат. Если пусто, то пусто, если число, то это число.
В первой группе показано как это должно выглядеть.

И второй вопрос. Как сделать, что бы при растягивании формулы она срабатывала только на группу, а не на значения в группе?
 
Формула в F389 и растягивайте на весь диапазон:
=ЕСЛИ(ЕТЕКСТ($A389);СУММПРОИЗВ((СЧЁТЕСЛИ(СМЕЩ($A$390;;;СТРОКА($A$390:$A$408-389);F$3)=СУММПРОИЗВ(--ЕТЕКСТ($A$389:$A389)))*(F$3=$A$390:$A$408*$D$390:$D$408;ЕСЛИ($A389=F$3;$D389;""))
"..Сладку ягоду рвали вместе, горьку ягоду я одна."
 
Не работает. Я так понял там 3 диапазона и они куда то сместились. Куда какой переместить?
excel.gif (75.67 КБ)
 
SuperLesh,так уберите для начала объединение ячеек, оно там ни к чему. Я бы добавил скрытый допстолбец, который напротив каждой даты подставлял наименование картриджа - очень упростит дальнейшие вычисленя
 
Файл для примера можно было бы и сократить.
"..Сладку ягоду рвали вместе, горьку ягоду я одна."
Страницы: 1
Читают тему (гостей: 1)