Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Подсчет суммы по параметрам за день
 
Приветствую, уважаемые знатоки.
Вопрос такой:
Есть книга из 2 листов. На 1 - сетка заработка по дням/часов. На 2 - сумма за конкретный день по категориям персонала. Как на 2 листе сделать автозаполнение по остальным дням, если данные берутся с первого листа? Реальные листы в несколько раз больше, и вбивать поэлементно руками надоело.
По сути, нужно, чтобы менялись буквы адреса ячейки в формуле 2 листа, а цифры оставались неизменными
Например, есть такое
="Лист1"!А1+"Лист1"!А3
="Лист1"!B1+"Лист1"!B3
Как сделать так, чтобы система при расчете подставила сама C,D...?

Пробовал растяжкой-автозаполнением - не работает.Как иначе - не знаю
Изменено: Z10n - 16 Апр 2015 10:59:56
 
Вы так хотели?
 
Оно нет
Код
=СУММПРОИЗВ(($A3='Учет времени'!$C$2:$K$2)*(B$2='Учет времени'!$B$3:$B$15)*СМЕЩ('Учет времени'!$C$3:$K$15;1;))
Лень двигатель прогресса, доказано!!!
 
Вариант.
 
jakim, нет

Сергей,похоже на правду, а если там где день, дата будет в формате 16.04.15?

gling, спасибо за помощь, Вариант Сергея мне показался проще.
 
должно работать если там и там будут даты, для этого и пишется в правилах приложите пример в реальной структуре
Лень двигатель прогресса, доказано!!!
 
Есть еще 1 сложность
В первой колонке второго листа, рассчитывается итог для барменов и официантов. Т.е. В реальной книге на первом листе есть категории бармен 1 кат, бармен 2 кат, официант 1 кат, официант 2 кат, и вот всех их необходимо считать в первую колонку второго листа, где бармены и официанты. Как это реализовать?
Изменено: Z10n - 16 Апр 2015 13:53:40
 
Z10n, дак приложите нормальный пример
Лень двигатель прогресса, доказано!!!
 
Изменено: Z10n - 16 Апр 2015 14:34:23
 
вариант с предварительной подготовкой где отпуск введено пользовательское форматирование, так как текст в диапазоне выдает ошибку, введен доп столбец для присвоения кодов должностей по которым будет группировка суммирования вобчем цветом выделил чтоб обратили внимание
Лень двигатель прогресса, доказано!!!
Страницы: 1
Читают тему (гостей: 1)