Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
подтягивание данных по двум условиям
 
Добрый день!

можете, пож-та, помочь.
1)см. в прикрепленном файле формулу в ячейке F347, когда протягиваешь формулу,
она перестает работать, см. ячейки F348-F354. диапазоны условия не меняются, не понимаю, почему возникает такая ошибка.
2) можно ли подтягивать данные по 3-м условиям, см. ячейку F365?

спасибо!
 
1) А зачем Вы номер столбца формулой ищите (второй ПОИСКПОЗ())? может так надо
Код
=ИНДЕКС($D$12:$D$304;ПОИСКПОЗ(F329;E$12:E$304;0);1)
какой результат должен быть в F348?
2) Одна тема - один вопрос (Правила форума однако...)
Согласие есть продукт при полном непротивлении сторон.
 
Добрый.
с первой формулой (в 347 строке) вам просто повезло. :)
ПОИСКПОЗ($D347;$B$12:$B$304;0) вот эта часть вашей формулы должна показывать, какой столбец из исходного массива в ИНДЕКС использовать для вывода ячейки.
В строке 347 эта часть формулы выдала 1 (и ИНДЕКС радостно выдал данные)
А в следующей строке - эта часть формулы выдала уже 50, а столько столбцов в исходном диапазоне ИНДЕКС нет, вот и ругань на #ССЫЛКА

Иными словами - формула не так составлена.
Кому решение нужно - тот пример и рисует.
 
 в ячейках F348-F354  должны подтягиваться названия брендов, также, как в ячейке F347  
 
Ну и? Формулу (пост #2) пробовали?
Согласие есть продукт при полном непротивлении сторон.
 
Цитата
Sanja написал: =ИНДЕКС($D$12:$D$304;ПОИСКПОЗ(F329;E$12:E$304;0);1)
да, знаю,что так можно,но в этом случае, двнные подтягиваются по одному условию- цена нет условие категории, даныне подтянутся неверно
 
проверяйте и далее аналогично
Лень двигатель прогресса, доказано!!!
 
Сергей, все верно,
спасибо большое!
Страницы: 1
Читают тему (гостей: 1)