Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Выбор значения, удовлетворяющего двум условиям
 
Помогите, пожалуйста, прописать формулу. Я уже испортил себе разум :(
Задача, казалось бы, проста:
Необходимо подобрать значение из столбца А, но диапазоны условий в столбцах B и C.

Во вложенной таблице постарался максимально подробно всё пояснить.
Заранее огромное спасибо!

P.S. Через вычисление площади логика не работает - этот вариант я уже продумал :)
 
Формула проверки количества вариантов:
=СУММ(--И(B2:B25<=B27;C2:C25<=C27))
Для заданных значений нет ни одного варианта.
 
Видимо, я не совсем верно пояснил.
=И(B2:B25>=B27;C2:C25>=C27) не меньше, а больше. При этом вернуться должно первое попавшееся значение по списку. Т.е., как я указал в самой таблице, подходит вариант BX-5U3. BX-5U4 и BX-5U тоже подходят, но они дороже.
 
Формула массива:
=ИНДЕКС(A1:A25;МИН(ЕСЛИ(B1:B25>=B27;ЕСЛИ(C1:C25>=C27;СТРОКА(B1:B25)))))
 
ну такой вариант без массивных с доп столбцом
Лень двигатель прогресса, доказано!!!
 
массивная без доп столбца
Код
=ИНДЕКС($A$2:$A$25;МИН(ЕСЛИ(($B$2:$B$25>=$B$27)*($C$2:$C$25>=$C$27);СТРОКА($1:$24))))
Лень двигатель прогресса, доказано!!!
 
Сегргей, формула покажет первое значение, если вариантов нет.
Моя тоже покажет первое значение, но мое первое лучше твоего :)
 
Всем большое спасибо!
Очень бы хотелось разобраться с вариантом vikttur, т.к. он работает, но как-то не так. Вернул вариант BX-5U4 вместо BX-5U3.
Вариант Сергея мне понятен и прост. Он работает :) Большое спасибо!
 
чет не подумал тогда нехай с доп столобцом

Цитата
vikttur написал: но мое первое лучше твоего
шапку в расчет брать не договаривались :D
Лень двигатель прогресса, доказано!!!
 
Лучше "шапка", чем проверка на отсутствие вариантов.

Цитата
Очень бы хотелось разобраться с вариантом vikttur... работает, но как-то не так
Ключевые слова - формула массива.
Ctrl+Shift+Enter
 
Ctrl+Shift+Enter - это я знаю

=ИНДЕКС($A$2:$A$25;МИН(ЕСЛИ(($B$2:$B$25>=$B$27)*($C$2:$C$25>=$C$27);СТРОКА($1:$24)))) - уррррра! То, что надо!

Сергей, еще раз спасибо. но с доп. столбцом мне было понятно... сейчас не очень :-(
 
Eduardo, у vikttur, формула заработает если уберете шапки на столбцом b и C и при отсутствии данных она не вернет неверный результат а выдаст вам контроллер
Лень двигатель прогресса, доказано!!!
 
Сергей, шапки я убрал сразу, но формула возвращала не тот контроллер.
 
Если вариантов нет (ИНДЕКС(диапазон;0)), функция покажет ПЕРВОЕ значение диапазона, что ошибочно.
Если в диапазон поиска добавить шапку, то функция при отсутствии  вариантов покажет текст шапки, что будет служить сигналом о том, что данных нет.

НО! Моя ошибка: не учел, что текст>числа, и формула всегда покажет первую строку!
Выход - добавить пустую строку и диапазон начинать с нее или добавить проверку на ошибку.
 
смотрим пример
Лень двигатель прогресса, доказано!!!
Страницы: 1
Читают тему (гостей: 1)