Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Функция "Если" с текстовым параметром в вычисляемых полях
 
Добрый день! Подскажите, пожалуйста, особенности использования формулы "Если" в вычисляемых полях.
Можно ли в зависимости от названия города вывести коэффициент (файл прикладываю)? Спасибо!
 
Добрый день!

Принцип такой, в ячейку вносите следующую запись, по примеру января по грушам в Киеве (ячейка E4):
Код
ЕСЛИ(A4="Груши";ЕСЛИ(B4="Киев";0;ЕСЛИ(B4="Харьков";1;"укажите город"));"выберите фрукты")
 
К сожалению не работает.
 
Функция ЕСЛИ в вычисляемых полях не работает с текстом, мне пришлось сначала в исходной таблице использовать функцию ЕСЛИ (добавился столбец), а потом уже обрабатывать с помощью сводной.  
 
Добрый вечер, пишу формулу =ЕСЛИ(В2>2120;"2120-В2"), выдает ложь, а как сделать чтоб в ячейке отображалось при соблюдении этого условия 0, и если истина то число
 
Ваш вопрос имеет к этой теме лишь косвенное отношение... Зачем там кавычки в формуле?
=ЕСЛИ(B2>2120;2120-B2;0)
 
Добрый день! Подскажите, пожалуйста, как прописать формулу:

В столбце "Доход/расход" текст в виде Д-01, Д-02, Р-01, Р-02 и т.д. В ячейку "Сумма" надо прописать условие, что если в ячейке из столбца "Доход/расход" содержится буква Д, то значение из столбца "Оборот...", в противном случае ноль. И, одновременно должно проверяться  условие с буквой Р по такому же алгоритму.

Спасибо.
 
Так похоже?
Код
=ЕСЛИ(ИЛИ(ЛЕВСИМВ(C3;1)="Д";ЛЕВСИМВ(C3;1)="Р");B3;0)
 
Игорь, добрый день!
Большое спасибо. Работает)))
А, если бы буквы Д и Р стояли не первыми, а где-нибудь в середине, например, ПрочД-01 и ПрочР-02? Тогда в формуле надо ставить цифру 4 вместо 1?
Изменено: КАлла - 27 Апр 2015 16:33:04
 
Алла,
нет, тогда вам надо делать например вот так.
Код
=ЕСЛИ(ИЛИ(ПРАВСИМВ(ЛЕВСИМВ(C3;5);1)="Д";ПРАВСИМВ(ЛЕВСИМВ(C3;5);1)="Р");B3;0)
 
KurS, добрый день! Спасибо большое! Все мне очень помогли!!!:)
Страницы: 1
Читают тему (гостей: 1)