Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Заполнение данными при выборе в конечной ячейке
 
Здравствуйте!

При выборе конечного результата "Пружина", заполнение конкретными данными именно выбранной пружины Толщина, Диаметр, Длина.
Калибровка у некоторых пружин одинакова, при пользовании ВПР, не соответсвию пружины, или ГПР.

Спасибо за помощь!
С уважением,
Роман
 
Формула массива для определения строки:
=МАКС(ЕСЛИ(K4:O12=A8;СТРОКА(K4:K12)-2))
А дальше просто:
=ГПР($A$10;$P$3:$R$12;ячейка_с_№строки;)
 
Можно для толщины, диаметра и длины использовать вот такую формулу (изменяя последнюю цифру - номер столбцов для вывода соотв.данных - 6,7,8):
Код
=ИНДЕКС(K4:R12;ПОИСКПОЗ($A$8;ИНДЕКС($K$4:$R$12;;ПОИСКПОЗ($A$6;K3:R3;0));0);6)

см. пример.
Изменено: Пытливый - 17 Апр 2015 13:21:04
Кому решение нужно - тот пример и рисует.
 
Всем, большое спасибо!
 
Всем доброго дня!
Выбор только при пересечении, работает, но при выборе в строках калибровку невыводит.
Задавать уникальность?

С уважением,
Роман
 
Цвет/производитель/наименование - одинаковы. И как машина поймет, какую из трех Вы хотите?
 
Здравствуйте!
Обозначена, каждая пружинка, заполнить Толщина, Диаметр, Длина.
Где моя ошибка?

Всем спасибо!
 
Самостоятельно вставить формулы из сообщения №2 никак?
 
Спасибо!
 
Всем, здравствуйте!
Заполнение данными по Производителю и Пружине.
Всем заранее спасибо!
С уважением,
Роман
 
Вы все вопросы в одну тему будете скидывать?
Я уже Вам писал: если пружины разные, нет необходимости искать по другим критериям.
 
Извините, за настойчивость.
Если пружины разные, то по выбору конкретной пружины нельзя заполнить Длина, Диаметр, Толщина?
 
Nalsur, кнопка цитирования не для ответа
По вопросу: что не нравится в файле в сообщении №8? Размеры показаны для конкретной пружины.
 
Vikttur, спасибо, все нравится, но при правке и применении удаляются { }. и выбор по цвету, теперь только один.
 
Цитата
Nalsur написал: при правке и применении удаляются { }
Формула массива вводится не простым нажатием на Enter, а Ctrl+Shift+Enter
 
Юрий М, огромное спасибо!  
Страницы: 1
Читают тему (гостей: 1)