Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
поиск значения по критериям и по последней дате
 
Здравствуйте!
как всегда к вам )))
опять не могу справится с данным решением
просьба помочь...
попробовал использовать данную формулу но не работает СУММЕСЛИМН($C$2:$C$7;$B$2:$B$7;B7;$A$2:$A$7;МАКС($A$2:$A$7))
подскажите может ее можно доработать или она сюда вообще не подходит?
если вообще не то...
Помогите с решением, пожалуйста!!!
 
У меня получилось, но немного громоздко и с допстолбцом (обе формулы массивные). В допстолбце (у меня F) вычисляем наибольшую дату по товару
Код
=МАКС(ЕСЛИ($B$2:$B$7=B2;$A$2:$A$7;))
В основном столбце вставляем такую формулу
Код
=ЕСЛИ(A2=F2;СУММПРОИЗВ(($C$2:$C$7)*($B$2:$B$7=B2)*($A$2:$A$7=F2));"")
Проверяйте
 
МВТ,
Спасибо!
работает
фигурные скобки поставил в допстолбце
а в основной формуле так работает...
или могут быть ошибки?
но попробовал по разному все по моему нормально)))
Спасибо еще раз!!!
 
Кстати, если Вам просто нужна таблица, где по каждому товару будет выводиться сумма его продаж за максимальную дату, можно обойтись без ЕСЛИ и без допстолбца (формула массивная)
Код
=СУММПРОИЗВ(($C$2:$C$7)*($B$2:$B$7=B2)*($A$2:$A$7=МАКС(ЕСЛИ($B$2:$B$7=B2;$A$2:$A$7;))))


 
МВТ,
подскажите , что из этого легче будет работать?
очень много строк до 40000
что бы тянуло потом
первый вариант работает нормально))))
 
МВТ,
у меня тут образовался не совсем верный результат
не много не правильно указал в примере
если в предидущей дате стоит кол-во а в последующей стоит ноль то должно выдавать последнее максимальное по дате не равное нулю
посмотрите пожалуйста пример
 
Иван Иванов, точно не знаю, но думаю, первый вариант пошустрее будет, там меньше "массивить". Попробуйте сравнить на реальной таблице и расскажите - мне самому интересно ;)
 
Можно и так использовав  комбинацию из ваших формул.
 
jakim,
так не работает...
в примере красным выделил
 
У Вас в ячейке С7 был 0, поэтому и формула показала 0.
 
jakim,
там все правильно

если в предидущей дате стоит кол-во а в последующей стоит ноль то должно выдавать последнее максимальное по дате не равное нулю
в этом как раз загвоздка
МВТ все сделал правильно но я не учел этот момент и как бы теперь работает не правильно
не совсем все правильно указал что хотел изначально
 
А так?
 
jakim, нет)))
или не правильно объясняю или не понимаете меня....
 
 
Всем спасибо!
все сделал
 
Цитата
Иван Иванов написал: ... или не правильно объясняю или не понимаете меня....
Оба ваши "или" верны. Однако, имхо, главное  в другом - ваша хотелка далека от реальной целесообразности ТАКОГО расположения результата - муторно, нет ясности и наглядности. Проще получить информацию не в доп поле, а, скажем, в отдельной таблице. Если вариант подходит, то обрисуйте как, где... ;)
"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
сделал так
 
Z,  
#6
18 Апр 2015 13:25:29
так же подходит
но я написал:
если в предидущей дате стоит кол-во а в последующей стоит ноль то должно выдавать последнее максимальное по дате не равное нулю
причем тут хотелка?
 
Цитата
Иван Иванов написал: причем тут хотелка?
"Хотелкой" мы тут называем то, что желает (хочет) получить автор :) Ничего обидного в этом слове не вижу.
 
Юрий М, я перечитываю. по моему все понятно было мной написано
МВТ сразу понял  что я хотел...
ну потом может не смог человек, и тд ... выходной в конце концов...
все сделано было им быстро
ну дальше как то так пошло
я не обижаюсь)))
 
Цитата
Иван Иванов написал: по моему все понятно было мной написано
Это ВАМ всё сразу понятно, а стороннему наблюдателю - не факт ) Так бывает, и очень часто. Я тоже иногда задаю кучу дополнительных вопросов, чтобы потом не переделывать.
 
 Юрий М,
как раз все помогают
уже сто раз написал Вам
очень отличный форум
Всем большое спасибо!!!
 
Иван Иванов, хорошее решение
Страницы: 1
Читают тему (гостей: 1)