Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Выборка из таблицы по нескольким параметрам
 
Добрый день. Есть 2 таблицы, в одной информация о работе техники на полях - дата, поле, трактор и тд, на другом листе посещения полей агрономами (дата, поле, агроном). Необходимо по дате и полю выводить в первую таблицу фамилию агронома. Буду весьма признателен за помощь. Пример прилагаю.
 
На листе Работа вставьте столбец D с формулой =A2&C2 и протянуть вниз
На листе Агроном вставьте столбец С с формулой =A2&B2 и протянуть вниз
Затем примените ВПР, в Е2 формулу =ВПР(D2;агроном;2;ЛОЖЬ)
агроном- это имя диапазона =Агроном!$C$2:$D$3
 
Как-то так
Код
=ИНДЕКС(Агроном!$C$2:$C$3;ПОИСКПОЗ(Работа!C2;ЕСЛИ(Агроном!$A$2:$A$3=Работа!A2;Агроном!$B$2:$B$3)))

Страницы: 1
Читают тему (гостей: 1)