Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Вытащить из списка названия по порядку игнорируя некоторые
 
Друзья! Доброго времени суток!
Насколько реально? (см.ниже)

Есть список (в нем перечень фирм и т.д.)
В нем кроме нужных названий есть еще некоторые "слова" или "фразы", которые не нужны
Можно ли какую то формулу придумать, чтобы получить список без ненужных "вхождений", чтобы в результате получился список, как в файле-примере (диапазон F6:F12 - сделан вручную)

Два момента:
1) заранее неизвестно начало списка (в примере начало списка - яч. B6), но по разным причинам начало списка может смещаться вверх или вниз
2) между заполненными ячейками - есть пустые, они тоже не нужны

(если формула получится сложная, то первое условие можно не учитывать)
Буду очень признателен за подсказки в каком направлении думать или за решение! (особенно - за решение!)
 
=ИНДЕКС($B$1:$B$20;НАИМЕНЬШИЙ(ЕСЛИ(МУМНОЖ(Ч($B$1:$B$20=ТРАНСП($D$2:$D$5));СТРОКА($D$2:$D$5)^0)=0;СТРОКА($B$1:$B$20));СТРОКА(A1)))
"..Сладку ягоду рвали вместе, горьку ягоду я одна."
 
одуренно! спасибо! то что надо!! как Вы это делаете? ну и формула!! а ТРАНСП там зачем? ) ведь оба массива - "вертикальные"..
 
А МУМНОЖ может сравнивать столбцы и строки.
"..Сладку ягоду рвали вместе, горьку ягоду я одна."
 
у мня попроще с доп столбцом
Лень двигатель прогресса, доказано!!!
 
Вот почему -то перстала работать корректно.. ((
добавил столбцы слева
формулу вручную корректировал, чтобы снова было СТРОКА(A1)
и добавил строки между списком наименований и верхней частью

по какой причине формула перестала работать? ведь принципиально ничего не изменилось вроде бы...
 
Цитата
Zhukov_K написал:  между заполненными ячейками - есть пустые, они тоже не нужны
Именно поэтому нужно брать диапазон с пустой ячейкой. В Вашем случае он должен быть - $F$2:$F$5.
"..Сладку ягоду рвали вместе, горьку ягоду я одна."
 
понял! спс!!!
 
Форула массива:
=ИНДЕКС($B$6:$B$20;НАИМЕНЬШИЙ(ЕСЛИ(СЧЁТЕСЛИ($D$2:$D$4;$B$6:$B$20)=0;ЕСЛИ($B$6:$B$20<>"";СТРОКА($B$6:$B$20)-5));СТРОКА(A1)))
Но с доп. столбцом лучше:
=ЕСЛИ(ИЛИ(СЧЁТЕСЛИ($D$2:$D$4;B6);B6="");;МАКС($A$5:A5)+1)
=ЕСЛИОШИБКА(ВПР(СТРОКА(A1);$A$6:$B$20;2;);"")


Примеры в файле
 
Спасибо, Vikttur! :-)
 
По мне, так лучше запросом. Файл должен находится в папке c:\1\
Неизлечимых болезней нет, есть неизлечимые люди.
 
Цитата
Владимир написал: СТРОКА($D$2:$D$5)^0
Владимир, а возведение в 0 зачем? в первом массиве Ч($B$1:$B$20=ТРАНСП($D$2:$D$5)) и так будут 0 или 1, и потом же всё равно делаем проверку =0, так что пофиг, что там во втором массиве, номера строк или единицы
F1 творит чудеса
Страницы: 1
Читают тему (гостей: 1)