Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Подсчет количества значений в четных или нечетных строках
 
Здравствуйте. Вопрос таков.

Есть некий массив
1 2 3 1 2 3
1 2 3 1 2 3
1 2 3 1 2 3

Необходимо подсчитать количество ячеек со определенным значением в четных или нечетных строках
Например: количество ячеек со значением "1" в нечетных строках массива равно 4
Не могу понять, как состыковать между собой ЕЧЕНТ, СЧЕТЕСЛИ и т.д.
 
для нечетных:
Код
=СУММПРОИЗВ(--(ОСТАТ(СТРОКА($A$1:$A$3);2)=1)*($A$1:$F$3=G1))
для четных:
Код
=СУММПРОИЗВ(--(ОСТАТ(СТРОКА($A$1:$A$3);2)=0)*($A$1:$F$3=G1))
в G1 - число, которое подсчитываем.
Даже самый простой вопрос можно превратить в огромную проблему. Достаточно не уметь формулировать вопросы...
 
Спасибо! Работает!! :)
 
И так тоже можно
Код
=СУММПРОИЗВ(--(ЕНЕЧЁТ(СТРОКА($A$1:$A$3);2)=1)*($A$1:$F$3=G1))
=СУММПРОИЗВ(--(ЕЧЁТН(СТРОКА($A$1:$A$3)))*($A$1:$F$3=G1))
F1 творит чудеса
Страницы: 1
Читают тему (гостей: 1)