Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Заполнение столбца данными из разных ячеек
 
Добрый день!
Подскажите, пожалуйста, какую формулу можно использовать для такого задания:
Есть 3 столбца с информацией, но не в каждой ячейке все заполнено. В четвертый столбец нужно внести значения по приоритету: если в первом столбце ячейка заполнена, то берем значение из него, если нет, то берем из второго столбца, если же и он не заполнен, то из третьего, если информации нет ни в одном из трех столбцов, то ячейку оставляем пустой.
 
Как Вам ответ давать? В чем?
 
vikttur, простите, не поняла вопроса. Как можете так и предоставьте, пожалуйста.
 
Пришлите ведро. Туда формулу положу.
Если ведра нет, прикрепите файл-пример.

Правила здесь
 
Желтым выделила ожидаемый результат
 
=ЕСЛИ(A2<>"";A2;ЕСЛИ(B2<>"";B2;ЕСЛИ(C2<>"";C2;"")))
=ЕСЛИОШИБКА(ПРОСМОТР(1;1/(A2:C2<>"");A2:C2);"")

Первая лучше
 
Спасибо!
Страницы: 1
Читают тему (гостей: 1)