Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Найти одинаковые ячейки в столбце
 
Здравствуйте, помогите пожалуйста разобраться.

Пример в файле, в столбце D, в каждой ячейке хранится значение в формате ХХ,ХХ,ХХ. Мне нужно узнать - какая именно ячейка и сколько раз - повторяется в этом столбце. В итоге должно получится, к примеру
23,25,52 - 22 повторов
55,34,32 - 17 повторов
67,34,11 - 15 повторов
и так далее. Спасибо.
Изменено: Hater - 22 Апр 2015 21:19:43
 
Закладка Данные, Текст_по_столбцам, разделитель - запятая.
После этого СЧЕТЕСЛИ по полученному массиву
 
Сводная таблица.
ps И, в первую очередь, "причесать данные" - пустоты зачем в них?!
"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
Извините, я ничего не понял) Поясните пожалуйста в режиме "Для новичка".

Разделять ничего не нужно, надо просто посчитать - какие ячейки целиком повторяются и сколько раз.
 
Для того, чтобы посчитать, лучше разделить.
Применяйте инструмент, о котором написал выше. Данные будет разднлены по ячейкам.
Далее примените функцию СЧЕТЕСЛИ
 
СЧЕТЕСЛИ там надо заполнить диапазон и критерий. Диапазон понятно, а критерий - что такое?
Изменено: Hater - 22 Апр 2015 20:34:29
 
Это то значение, которое нужно считать.
В справке по функции и примеры есть.
 
Цитата
какая именно ячейка и сколько раз - повторяется в этом столбце
Стоп! если не отдельные числа ячеек, а ячейки целиком, то разбивать данные не нужно. Только СЧЕТЕСЛИ
 
Именно!
Посмотрел примеры, не увидел того что мне нужно. Подскажите пожалуйста - что указать в критерии?
 
Смеетесь?
=СЧЕТЕСЛИ(диапазон; A1)
 
Цитата
В итоге должно получится, к примеру
23,25,52 - 22 повторов
Такой комбинации не обнаружено, откуда пример?
 
vikttur, Посмотрите пожалуйста файл, что то я неправильно делаю, везде нули получаются.
 
=СЧЁТЕСЛИ(D:D;D2)
 
vikttur, Спасибо! Теперь можно как нибудь подсветить или показать вверху листа - ячейки у которых более 5 повторов? К примеру в А чтоб все ячейки со значением более 5 - были залиты красным.
Kuzmich, Значения в примере - условные.
Изменено: Hater - 22 Апр 2015 23:26:25
 
Вопрос не по теме
Страницы: 1
Читают тему (гостей: 1)