Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Отбор в массиве данных нужного значения
 
Здравствуй форумчане! Прошу вашей помощи! в примере приведена табличка и в ней задачка, которую решить у меня не хватает извилин..(((
 
Формула массивная (вводится через Ctrl-Shift-Enter)
Код
=ИНДЕКС($G$2:$G$8;МАКС(ЕСЛИ($C$2:$C$8=C10;СТРОКА($A$2:$A$8)))-1)

 
МВТ, спасибо за быструю помощь)) Если не сложно, может поможете в улучшении
формулы? В формуле массив задан конкретно, а если я вставлю еще 50
значений, то формула распространятся на них не будет, как переделать в
динамичные массив? может массив задавать так
=$G$1:ДВССЫЛ(АДРЕС(СТРОКА()-1;7;4;1);ИСТИНА)?
Изменено: qwerty2015 - 23 Апр 2015 11:16:00
 
qwerty2015, кнопка цитирования не для ответа.
Исправьте сообщение.
 
vikttur спасибо за поправку))
 
Вы не поняли.
Цитировать нужно с умом. И если нужно
 
Переделайте свою таблицу в "умную" (выделите, примените "Форматировать как таблицу", обязательно поставьте галку на заголовках) и формула станет такой (все равно массивная):
Код
=ИНДЕКС(Таблица1[Осталось бензина];МАКС(ЕСЛИ(Таблица1[Автомобиль]=C10;СТРОКА(Таблица1[Дата выезда])))-1)

Страницы: 1
Читают тему (гостей: 1)