Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Автоматическое продолжение столбца с формулой при добавлении новых исходных значений в соседний столбец (Excel 2010)
 
Здравствуйте, уважаемые специалисты по Excel.
К сожалению, второй день ни на Вашем форуме, ни на других ресурсах Интернета я не могу найти ответа на нижеприведенный вопрос.
Есть столбец В, в котором вычисляются средние значения из значений, находящихся в столбце А по формуле =СРЗНАЧ($A$1:A1), СРЗНАЧ($A$1:A2) и так далее.
Что нужно добавить к вышеприведенной формуле в столбце В, чтобы при введении очередного значения в столбец А, в столбце В формула автоматически переходила в следующую строку и вычисляла следующее среднее значение?
Не знаю, может быть, это важно для ответа на мой вопрос – средние значения из столбца В мне нужны для создания динамического именного диапазона для отображения этих средних значений на диаграмме.
Используется программа Excel 2010.
Маленький файл с примером из 7 ячеек прилагается.
Заранее большое спасибо за Вашу очень ценную для меня помощь.
Изменено: Широков - 23 Апр 2015 14:12:27
 
Преобразуйте в "умную таблицу", используя инструмент "форматировать как таблицу".
 
Можно сделать умную таблицу
Неизлечимых болезней нет, есть неизлечимые люди.
 
можно так выкрутится растянуть подальше вниз
Код
=ЕСЛИ(A1="";"";СРЗНАЧ($A$1:A1))
Лень двигатель прогресса, доказано!!!
 
Спасибо большое за Ваши советы, хотя они и не привели к нужному мне результату (см. ниже) :(
------------------------------------------------
Совет Маргариты
Цитата
Преобразуйте в "умную таблицу", используя инструмент "форматировать как таблицу"
Может быть, я не так выполнил какие-либо действия (они описаны ниже)?
В вышеприведенном файле примера "вопрос.xlsx" я полностью выделил столбцы А и В и нажал на названную Вами кнопку "Форматировать как таблицу" на вкладке "Главная", затем из открывшегося списка я выбрал левый верхний стиль таблицы.
После этого моя таблица стала полосатой, но при добавлении новых значений в столбец А,  в столбце В формула не переходит в следующую строку и не вычисляет следующее среднее значение.
Буду очень благодарен, если кто-то укажет мне на ошибку в моих действиях.
------------------------------------------------
Совет  TheBestOfTheBest
Цитата
Можно сделать умную таблицу
Получившаяся у TheBestOfTheBest таблица действительно при добавлении значений в столбец А автоматически вычисляет следующие средние значения в столбце В, но эти средние значения каждый раз одни и те же  начиная от 5-ой строки и ниже.
См. в приложении получившуюся таблицу.
В то время как я по указанной мною в предыдущем сообщении формуле (=СРЗНАЧ($A$1:A1), СРЗНАЧ($A$1:A2) и так далее) отслеживал динамику изменения средних значений.
И как я писал выше, мне нужно отражать эту динамику на графике .  
------------------------------------------------
Совет Сергея
Цитата
можно так выкрутится растянуть подальше вниз
=ЕСЛИ(A1="";"";СРЗНАЧ($A$1:A1))
При вставке формулы Сергея в ячейку 1 столбца В и растягивании её подальше вниз, после внесения новых значений в столбец А, столбец В действительно расширяется вниз и правильно рассчитывает средние значения в их динамике.
Но динамический именованный диапазон, имеющий имя «Средние_значения» учитывает все ячейки, выглядящие пустыми, но содержащие формулу Сергея.
Этот диапазон рассчитывается по формуле =СМЕЩ('Лист1'!$B$1;0;0;СЧЁТЗ('Лист1'!$B:$B))
Поэтому на графике ячейки, в которые была «растянута подальше вниз формула», выглядят как ячейки, в которых якобы стоят нули, а не как пустые ячейки.
См. в приложении файл с получившимся графиком.
В этом случае, как мне кажется, нужно менять либо формулу расчета динамического именованного диапазона (чтобы эта формула не учитывала ячейки с формулами), либо формула Сергея не подходит для решения этой задачи.
------------------------------------------------
Буду Вам очень признателен за еще какие-либо советы.
Изменено: Широков - 23 Апр 2015 14:11:31
 
ну с моей формулой нужно просто поменять в формуле определения диапазона счетз (которая считает любое значение) на счет (которая считает числовые)
так?
Лень двигатель прогресса, доказано!!!
 
Посмотрите соседнюю тему http://www.planetaexcel.ru/forum/index.php?PAGE_NAME=read&FID=1&TID=65655&TITLE_SEO=65655-umnye-tabl... Там ответ на ваше "не работает".
Изменено: Margarita - 23 Апр 2015 13:53:00 (Добавлен файл.)
 
поробуйте использовать формулу =СРЗНАЧ(ДВССЫЛ("$A$2:A"&СТРОКА();ИСТИНА))
Неизлечимых болезней нет, есть неизлечимые люди.
 
Для умной таблицы используйте формулу:
=СРЗНАЧ($A$2:ИНДЕКС(A:A;СТРОКА()))
 
Всем спасибо большое за советы.
Мне понадобится какое-то время, чтобы протестировать, как работают рекомендованные формулы.
Немного попозже я напишу в этой теме о результатах.
 
Протестировал я свою таблицу с рекомендованными формулами – в общем, всё работает так как надо.
Спасибо Маргарите и TheBestOfTheBest за информацию об умных таблицах, о существовании которых я узнал только пару дней назад.
Сергею и Михаилу С. особое спасибо за формулы – в моей таблице необходимо было расширять столбцы на нескольких листах, и в одних случаях было целесообразнее использовать формулу Михаила, а в других формулу Сергея.
------------------------------
И у меня появился вопрос по умной таблице.
Насколько я знаю, при образовании умной таблице первая строка диапазона автоматически превращается в заголовки столбцов (см. описание нескольких способов создания умных таблиц здесь).
Но TheBestOfTheBest как-то смог преобразовать мою таблицу в умную таблицу таким образом, что первая строка осталась строкой с числовыми значениями, а не стали заголовками (см. прикрепленный файл).
Не могли бы Вы подсказать, как это делается?
Изменено: Широков - 23 Апр 2015 17:28:47
 
Вставил первую строку, потом преобразовывая убрал галочку (там она одна). Далее Конструктор-Параметры стилей-Срока заголовка-убрать
Изменено: TheBestOfTheBest - 23 Апр 2015 17:39:45
Неизлечимых болезней нет, есть неизлечимые люди.
 
И у меня получилось.
Еще раз большое спасибо.
 
Широков, кнопка цитирования не для ответа.
И эту фразу я пишу раз 15 в день. Тоска... Люди не понимают...
Страницы: 1
Читают тему (гостей: 1)