Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
функция ВПР / как искать НЕ ПО ПЕРВОМУ столбцу ?
 
В таблице примере 3 столбца- артикул/наименование/описание.
Использую функцию ВПР.
Если искать по первому столбцу и выводить данные из 2 и 3 - то всё ок.
Как искать по второму столбцу и выводить данные из 1 и 3?

С ВПР фантазировать или совсем на другие способы смотреть?
Исходную таблицу нельзя модифицировать (менять местами столбцы, сортировать и тп).
---------
Реальная ситуация - есть большой прайс, который лежит в сети и который нельзя никак изменять, он периодически обновляется, название остается то же.
Нужно excel-костыль, который по названию продукта (находится во 2 столбце прайса) из выпадающего списка будет выводить прочие данные - артикул (1 столбец), описание (3 столбец), цену и тп.
 
А такой вариант не проходит?
Код
=INDEX(A6:A11;MATCH(B4;B6:B11;0))
 
Цитата
d0ppe1ganger написал: искать по второму столбцу и выводить данные из ... 3?
Сделать второй столбец первым и выводить данные из второго
Код
=ВПР(B4;B6:C11;2;0)
для "левого" ВПР используйте другие функции
Согласие есть продукт при полном непротивлении сторон.
 
Надстройкой PLEX пользуетесь?
По-моему в ней есть функция VLOOKUP3.
Изменено: К К - 26 Апр 2015 15:12:12
 
jakim, Sanja, спасибо, индекс/поискпоз помог решить вопрос!
 
Есть и такой вариант использования ВПР()
Код
=VLOOKUP(B4;CHOOSE({1\2};$B$6:$B$11;$A$6:$A$11);2;0)
 
Hugo, тонко!
Страницы: 1
Читают тему (гостей: 1)