Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Поиск по нескольким словам
 
Добрый день! Есть таблица данных(столбец В), есть массив контрольных слов(столбец Н). Из таблицы данных(В) я вытаскиваю те строчки, которые содержат хотя бы одно слова из массива(Н). Как мне прописать условие так, чтобы вытащить строчки, которые содержат определенный набор нескольких слов. Из вложенного примера сейчас ищет строчки, содержашие или слово "ком", или "мар", или "ука". Хочу еще вытаскивать строчки содержащие 2 слова "отв" и "адр" одновременно
 
Если правильно понял...
Конь, просто конь.
Удивление есть начало познания © Surprise me!
И да пребудет с нами сила ВПР.
 
Ёк-Мок, спасибо! Но тогда туда попадут и все строчки, которые содержат только "отв" или только "адр", а мне надо, чтобы именно 2 слова были в одной ячейке((((
 
для вашего примера в ячейке с искомыми данными поставьте так отв*адр
Лень двигатель прогресса, доказано!!!
 
Или:
=ЕСЛИОШИБКА(ПРОСМОТР(99;ПОИСК(ПОДСТАВИТЬ($H$2:$H$5;" и ";"*");B2));)
"..Сладку ягоду рвали вместе, горьку ягоду я одна."
 
Цитата
Сергей написал:  поставьте так отв*адр
Спасибо! Работает
 
Владимир , спасибо!
Страницы: 1
Читают тему (гостей: 1)