Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Циклическая ссылка
 
Здравствуйте. Есть формула которая высчитывает сроки по вот такой формуле. Но она циклическая. Как ее упростить что бы она не была такой? Более подробное описание в файле.
Код
=ЕСЛИ(ЕСЛИ(Y5="остаток";ЛОЖЬ;ЕСЛИ(Y5="";ЛОЖЬ;ИСТИНА));J5;РАЗНДАТ(F5;СЕГОДНЯ();"m")&","&РАЗНДАТ(F5;СЕГОДНЯ();"md"))
Изменено: Gremlen - 29 Апр 2015 09:10:36
 
она у Вас не должна ссылаться на ту ячейку, в которой сама записана, вот и всё. А идеи Вашей я не смог уловить. Что должно в итоге быть в С, когда в D например "прокурору"?
 
Должен быть срок рассчитанный ранее. Т.е. пока ячейка столбца D пестая, формула вычисляется(и вычисляет она например 2,16), а как только в D  появиться например прокурору, то вычислять срок формула должна перестать и оставить значение 2,16.
 
не понял но может оно просто сделать ссылку на С1
Лень двигатель прогресса, доказано!!!
 
Откуда формула возьмет 2,16? Если вычислять перестанет? М.б. Вам лучше сделать столбец, в который заносить дату передачи прокурору? В столбце E, например?
Тогда формула будет такая  =ЕСЛИ(ИЛИ(D2="остаток";D2="");РАЗНДАТ(B2;СЕГОДНЯ();"m")&","&РАЗНДАТ(B2;СЕГОДНЯ();"md");РАЗНДАТ(B2;E2;"m")&","&РАЗНДАТ(B2;E2;"md"))
Страницы: 1
Читают тему (гостей: 1)