Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
АВС-анализ в общей таблице по отдельным группам, накопительное суммирование по отдельным параметрам
 
День добрый. Прошу совета у знающих людей.
Задача - есть отчёт о продажах по разным группам товаров. Надо присвоить каждому товару в группе категорию по АВС анализу. Уперлась в проблему: как накопительно подсчитать проценты конкретно по каждой группе в общей таблице, где вперемешку несколько групп. Предполагаю, что нужно использовать формулу ДВССЫЛ и СМЕЩ, но не получается их "осознать". Надеюсь на вашу помощь.
Ирина.
 
Если правильно понял, что с чем суммировать
Код
=СУММЕСЛИ($A$2:A3;A3;$M$2:M3)


 
Да. Этот диапазон

Например есть группы Смесители в массиве. Доля каждого товара в этой группе я выделила.
Товар 1- 5%
Товар 2 - 4%
Товар 3 - 2%

Рядом в столбике должны накопительно суммироваться эти доли
смесы     Товар 1- 5% -           5%
ванны      товар1
смесы     Товар 2 - 4%         = (5%+4%)=9%
керамика  товар 2
смесы     Товар 3 - 2%         =(5%+4%+2%)=11%
и т.д.
проблема в том, что групп много и в накопительный столбик должны попадать товары только из одной группы  
Изменено: phil3 - 29 Апр 2015 10:41:58
 
Давно не делал, но, думаю, можно и через сводные таблицы, например как в приложенном файле.
С уважением,
Федор/Все_просто
 
Спасибо за вариант. Думала об этом, но цель мероприятия автоматизировать весь расчёт без ручных манипуляций, так как товарных групп больше 100, а АВС нужен по товарам только внутри каждой группы, а не по всему ассортименту целиком.
 
А что тут сложного? Это легко можно автоматизировать, было бы желание и время.
А ежели нужно внутри каждой группы, так это тоже можно сделать. Достаточно поочередно менять поля. Вычисления же остаются теми же.
Макрос очень легко решит проблему автоматизации. Можно сделать, чтоб график обновлялся в зависимости от того, какая группа выбрана. Повторюсь: все решаемо.

UPD: кажется кто-то уже задавался подобным вопросом: в excel есть надстройка анализ данных - там по-моему есть что-то, что может помочь. Ищите.
Изменено: Все_просто - 29 Апр 2015 12:00:29
С уважением,
Федор/Все_просто
 
Если бы нашли, не спрашивали бы, а если бы и макросы писали.. :-) Может не дописала, что цель итоговая - по присвоенной категории, ВПР затягивается в другую таблицу с более чем 20000 позиций и на основании значения А,В или С выполняются уже другие операции. График не нужен. А если каждый раз поочередно менять поля.... это не проблема, проблема в просчёте в массиве разных данных без игрищ фильтрами и т.д. конкретной позиции в рамкой одной из товарных группы присваивалось на основании вычислений А В или С.
Изменено: phil3 - 29 Апр 2015 12:27:39
 
вот это не годится?
Код
=СУММЕСЛИ($A$2:$A2;$A2;$M$2:$M2)

и тянем вниз.
Сейчас, я вижу, что отсортировано по уровню дохода, но если сортировка изменится - то тогда, конечно, накопительный итог будет неверным (в целях АВС). Так что смотрите за ним внимательно :)
F1 творит чудеса
 
Спасибо. Я уже так сделала :-). Будем глубже изучать каверзные формулы
 
Вообще-то сводная может делать расчет в разрезе товарных групп. Непонятно только каким образом и какие категории присваиваем?
Изменено: TheBestOfTheBest - 30 Апр 2015 16:02:15
Неизлечимых болезней нет, есть неизлечимые люди.
Страницы: 1
Читают тему (гостей: 1)