Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Сумма ячеек в заданном диапазоне с несколькими условиями
 
Порылся в интернете не могу найти формулу позволяющую справится с моей задачей. в прилагаемом файле очень наглядно освещена проблема. суммесли, суммеслимн не помогают решить мою задачу, в excel многих формул не знаю, подскажите если кто знает.  
 
Как-то так, но у Вас неправильный формат данных в колонке A (судя по всему, текстовый, вместо Время)
Код
=СУММЕСЛИМН($B$2:$B$2683;$A$2:$A$2683;">=" & F2;$A$2:$A$2683;"<"  & F3)

 
Работает
Код
=SUMPRODUCT(($A$2:$A$3000>="10:00:00")*($A$2:$A$3000<="10:00:59")*$B$2:$B$3000)
Брать критерии из ячеек не получилось, форматы мешают видимо...
 
МВТ , если не затруднит, есть возможность вставить эту формулу в мой файл и загрузить снова в эту тему. т.к. я дилетант в этом деле у меня в итоге (после вставки этой формулы) получается 0  
 
я бы добавил еще одну колонку(В1:B), в который бы  =ВРЕМЗНАЧ(A2)
а на основании ее - для расчета суммы в заданном вами диапазоне - =СУММПРОИЗВ(($B$2:$B$2685>=ВРЕМЯ(10;0;0))*($B$2:$B$2685<=ВРЕМЯ(10;0;59))*C2:C2685)
 
адаптированая формула Hugo,
Код
=СУММПРОИЗВ((--$A$2:$A$3000>=F2)*(--$A$2:$A$3000<=G2)*$B$2:$B$3000)
Лень двигатель прогресса, доказано!!!
 
Спасибо ребят за представленные решения моей задачки. Очень помогло...
 
Сергей, спасибо, и впрямь заработало и на первом файле:
Код
=SUMPRODUCT((--$A$2:$A$3000>=F2)*(--$A$2:$A$3000<F3)*$B$2:$B$3000)
 
:)  Игорь ты просто запамятовал данный прием
Лень двигатель прогресса, доказано!!!
Страницы: 1
Читают тему (гостей: 1)