Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Если "текст содержит" то задать в другом столбце значение
 
Подскажите пожалуйста, как можно реализовать такой пример:
Есть столбец А, который содержит:
Купи Лист - получи подарок
Купи Картон - получи подрок
Купи Нож - получи подарок
Купи Лист - получи пачку бумаги
Сделать надо следующее: Если столбец А содержит "кар" то задать в столбце В Картон
 
annchousinka, с вас пример в виде эксель файла в котором руками указываете в столбце В что хотели бы получить формулой
Лень двигатель прогресса, доказано!!!
 
Вот прилогаю пример:
 
вариант
Лень двигатель прогресса, доказано!!!
 
А без дополнительно столбца никак нельзя?
Просто это файл с различными Акциями их может быть 100 штук и больше
 
если у вас все как в примере можно вытянуть слово поле "Купи" вот формула в В1 и тянем вниз
Код
=ПСТР(A1;6;ПОИСК("-";A1)-7)
Лень двигатель прогресса, доказано!!!
 
Нет могут быть разные слова:

Купи Лист - получи подарок
Демонтсрация Аквакраски
Поездка Лист Европа
 
Тогда вы сварганте нормальный пример близкий к вашей жизни, и опишите логику как должна работать формула определить что нужно выбирать, второе слово слово после определенного знака и тд.и т.п.  
Лень двигатель прогресса, доказано!!!
 
так бы всё ничего...
срация краски настораживает.
фрилансер Excel, VBA - контакты в профиле
"Совершенствоваться не обязательно. Выживание — дело добровольное." Э.Деминг
 
ikki, новые технологии производства краски :D
Лень двигатель прогресса, доказано!!!
 
Суть в том что мне нужно чтоб допустим Если в Ячейке содержится "лис", то в ячеке В получалось значение Лист
Если Ячейка содержит "Крас" , то в ячейке В получалось бы значение Краска
Слова в столбце А могут склоняться по этому нужен какой-то поиск по части слова.
И название самой акции может быть разной длины, по этоу привязывать к количеству символов или после "-" не подойдет
 
=ЕСЛИ([@[Name_shares]]="Купи лист - получи подарок";"КНАУФ-лист";(ЕСЛИ([@[Name_shares]]="Купи клей - получи подарок";"Клей";"1")))
Я пробывала сделать так, но тут проблема в том что, нужно прям конкретную акцию точно писать, что мне не подходит
 
вариант
фрилансер Excel, VBA - контакты в профиле
"Совершенствоваться не обязательно. Выживание — дело добровольное." Э.Деминг
 
Не вариант т.к. этих акция целая куча и задавать для кажой сокращение не вариант.
 
Если я правильно понял, Вам надо вытаскивать слово, которое содержит искомый корень. Всё-таки непонятно, где Ваша формула должна брать "корень" для поиска, если не из доп. столбца?
 
причем тут сокращение?
вы хотели "поиск по части слова" - это он и есть.
а поиск по заранее неизвестной части неизвестных слов - это на сайте gadalka.ru
фрилансер Excel, VBA - контакты в профиле
"Совершенствоваться не обязательно. Выживание — дело добровольное." Э.Деминг
 
М.б. с помощью UDF небольшой?
Страницы: 1
Читают тему (гостей: 1)