Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Выбор одинаковых позиций из 4 столбцов
 
С добрым утром.
Возникла необходимость в поиске одинаковых товаров.
Имеется два склада Магнит и Пятёрочка.
Как можно пометить одинаковые позиции товаров, которые имеются и там и там.
Реализация необходима на формулах.
Подробнее продемонстрировано в примере.
Никаких врагов, зато и никаких друзей.
 
Здравствуйте! Может так? Формула массива.
Код
=--ИЛИ(A2=$E$2:$E$12;A2=$F$2:$F$12;B2=$E$2:$E$12;B2=$F$2:$F$12)
 
gling Большое спасибо. Всё хорошо работает. Не понял только один нюанс. Как предположим заменить 1 на какую-то другую метку?
И ещё один момент. Если массив имеет формат E:E, то Excel начинает очень долго думать. Этого можно как-то избежать?
Изменено: CAHO - 2 Май 2015 11:05:55
Никаких врагов, зато и никаких друзей.
 
Можно так. Формула массива.
Код
=ЕСЛИ(ИЛИ(A2=$E$2:$E$12;A2=$F$2:$F$12;B2=$E$2:$E$12;B2=$F$2:$F$12);"Метка";"")
Нужно ли Вам 1048576 строк? Обозначьте массив конкретными значениями, до максимально большого.Например E2:E10000.
Изменено: gling - 2 Май 2015 12:02:51
 
Цитата
gling написал: Нужно ли Вам 1048576 строк?
Дело в том, что строки из массива регулярно удаляются в большом количестве. Т.е. получается, что массив будет уменьшаться и со временем не все позиции будет учитывать.
Хотя, если его обозначить через ИНДЕКС, то он останется постоянным. Надо попробовать.
Проверил. Всё работает как надо.
Записал формулу массива через индекс
Код
{=--ИЛИ(A2=ИНДЕКС(E:E;2;1):ИНДЕКС(E:E;12;1);A2=ИНДЕКС(F:F;2;1):ИНДЕКС(F:F;12;1);B2=ИНДЕКС(E:E;2;1):ИНДЕКС(E:E;12;1);B2=ИНДЕКС(F:F;2;1):ИНДЕКС(F:F;12;1))}
Изменено: CAHO - 2 Май 2015 18:23:33
Никаких врагов, зато и никаких друзей.
Страницы: 1
Читают тему (гостей: 1)