Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Записать в одну ячейку сумму диапазона (смещение и по строкам и по столбцам)
 
Помогите, пожалуйста, :( составить формулу со СМЕЩ (и по строкам и по столбцам одновременно). Подробно во вложении.
 
Как-то так, только объединение ячеек в строке дат на Лист1 снимите и все колонки датами заполните
Код
=ИНДЕКС(Лист1!$D$5:$FB$10;ПОИСКПОЗ(Лист2!$B$3;Лист1!$A$5:$A$10;0);ПОИСКПОЗ(Лист2!$A10;Лист1!$D$2:$FB$2;0))


 
И Вам здравствуйте mirola. Вариант в файле без СМЕЩ(). Длинновата правда формула.
Код
=СУММ(ИНДЕКС(Лист1!$D$5:$FB$10;ПОИСКПОЗ(B$3;Лист1!$A$5:$A$10;0);ПОИСКПОЗ($A10;Лист1!$D$2:$FB$2;0)):ИНДЕКС(Лист1!$D$5:$FB$10;ПОИСКПОЗ(B$3;Лист1!$A$5:$A$10;0);ПОИСКПОЗ($A10;Лист1!$D$2:$FB$2;0)+4))
Цитата
объединение ячеек в строке дат на Лист1 снимите и все колонки датами заполните
Если прописать даты в строке (в примере строка 4) можно без ИНДЕКСА и ПОИСКПОЗ. Файл перевложил.
Изменено: gling - 3 Май 2015 22:12:06
 
gling, точно, а то я индекс взял, а сумму забыл :)
 
Добрый вечер всем (gling, я исправилась :oops:). БОЛЬШУЩЕЕ СПАСИБО!:) Все заработало...надо было вчера написать, целый день со СМЕЩ мучилась!  
Страницы: 1
Читают тему (гостей: 1)