Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Сравнение цен: анализ ценовых предложений
 
По работе приходится часто анализировать ценовые предложения на аналогичные группы товаров и для наглядности хотелось бы добавить колонку, в которой можно было бы увидеть, какой из поставщиков предлагает минимальную среднюю цену и насколько выше цены конкурентов. В итоге у меня получилась громоздкая формула, которая для таблицы из предложений всего трех поставщиков по девяти однородным товарам выглядит так:
=СРЗНАЧ(C4:K4)/МИН(СРЗНАЧ($C$4:$K$4);СРЗНАЧ($C$5:$K$5);СРЗНАЧ($C$6:$K$6))-1
Но с ней есть две проблемы:
1. Она некорректно считает отклонения, если отсутствует цена хотя бы в одной из ячеек;
2. Если добавляется хотя бы одна новая строка или столбец её приходится вручную корректировать (можно, конечно, воспользоваться заменой по диапазону, но это все равно не слишком удобно).
Может кто-нибудь предложит лучшее решение задачи?
 
Цитата
jkr написал: минимальную среднюю цену
как это?
покажите в файле, что есть и что хотите
 
Прилагаю табличку, для наглядности с минимумом строк и столбцов.
 
с доп.столбцом
 
По-моему ваше решение не устраняет только вторую проблему, которая была не так существенна
 
Файл.

Формула массива (ФМ) вводится Ctrl+Shift+Enter
Memento mori
 
JayBhagavan, точно я переборщил :)
 
Цитата
jkr написал:
По-моему ваше решение не устраняет только вторую проблему, которая была не так существенна
А может я и ошибаюсь, нужно подумать, спасибо всем за помощь!
Страницы: 1
Читают тему (гостей: 1)
Наверх