Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
как найти в ячейке слово из диапазона?, НАЙТИ в ячейке слово из диапазона
 
Подскажите, пожалуйста, как найти в строке, содержащей несколько слов, любое слово из диапазона.

Первое, что пришло в голову: {=НАЙТИ(диапазон;строка)}
Если в диапазоне в первой ячейке есть слово, содержащееся в строке, то "найти" его находит.
Если слово содержится в диапазоне не в первой ячейке, "найти" его не находит, выдает ошибку.

Думал над вариантом с ЧАСТОТА, но что-то тоже не родилось ничего толкового.
Поиск в гугле и внутре Планеты выдает, как правило, "как найти совпадение ячеек с ячейкой из диапазона".
Можно, конечно, распарсить строку и сравнивать с диапазоном каждое слово, но как-то некрасиво, грубо и не будет работать для строк с большим количеством слов внутре...

Помогите, пожалуйста!
Прилагаю пример. Фрагмент реальных данных в первой колонке, диапазон в третьей, и во второй колонке моя попытка сделать сравнение.
Микрософт Офис профессиональный плюс 2013 64-битный. Легальный, на работе.

Спасибо!
Интересно, почему у чайников кривые ручки?
 
Формула массива:
=ИНДЕКС($C$1:$C$3;МИН(ЕСЛИ(ЕЧИСЛО(НАЙТИ($C$1:$C$3;$A1));СТРОКА($C$1:$C$3))))
Первым значением диапазона $C$1:$C$3 записать "нет" или что-то похожее - если ни одного слова нет в текстовой строке, то отобразится первое значение диапазона.
 
Круто! Искать в массиве ошибок число - здорово придумано. Спасибо!

А можно вопрос - почему не работало очевидное простое решение, которое я пытался применить? Смотрел через отладку - оно не преобразует в массив. Почему же в Вашем варианте НАЙТИ преобразует, а в моем - нет?
Интересно, почему у чайников кривые ручки?
 
Почему же? Выделить Вашу формулу в строке формул, нажать F9. В строке формул - массив из трех ошибок или из одного числа и двух ошибок.
 
Цитата
vikttur написал: Выделить Вашу формулу в строке формул, нажать F9
Шаманство, однако...
Но если нажать кноповку отладки (которая "Вычислить формулу"), то там для моей формулки такого не получается. А для Вашей - чудесным образом получается.  
Интересно, почему у чайников кривые ручки?
 
Никогда не пользуюсь...
Возможно,, из-за ошибки, которую Ваша формула не обходит.
Надо:
ЕЧИСЛО(НАЙТИ($C$1:$C$3;$A1))
 
Простите мою навязчивость, а как же Вы сложные формулы проверяете, как они внутре работают и где глючат? Неужто в голове?
Интересно, почему у чайников кривые ручки?
 
Цитата
phaggi написал:  как же Вы сложные формулы проверяете
В голове и в строке формул, там все видно.
Иногда часть формулы проверяется отдельно.
 
Если слов три-четыре, можно формулу облегчить. Вариант для размышлений (обычная, немассивная):
=ПСТР(A1;МИН(ПОИСК({"бульвар";"проспект";"площадь"};$A1&"бульварпроспектплощадь"));9)
 
Угу. Ага. Эта длиннаяколбаса в конце прибавляется, чтобы ошибки не было? Лихо. Все в голове переворачивается.
Интересно, почему у чайников кривые ручки?
Страницы: 1
Читают тему (гостей: 1)
Наверх