Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Формула ЕСЛИ с перебором значений из диапазона
 
Здравствуйте! мои знания по части формул в excel пока ограничиваются только арифметическими действиями.
Появилась необходимость написать не совсем обычную формулу ЕСЛИ.

Смысл такой.
Если значения в ячейки А1 из диапазона F1:F12, то пишем в A2 - 1, если значение А1 из диапазона G1:G12, то пишем A2.

Можно ли реализовать такую функцию посредством формул без использования VBA?  
 
Формулы удобнее писать в файле Excel (правила. п.2.3. Как есть - Как надо)
Согласие есть продукт при полном непротивлении сторон.
 
Вам бы правила почитать.
Я сам - дурнее всякого примера! ...
 
Здравствуйте.
Поясните, что значит "из диапазона"? Равно значению какой-либо ячейки этого диапазона?
Если да, то можно реализовать с помощью формулы массива:
Код
=ЕСЛИ(СУММ(--(А1=F1:F12))>=1;1;ЕСЛИ(СУММ(--(А1=G1:G12))>=1;2;"Значение А1 нет в этих диапазонах"))


Формула МАССИВА!
Изменено: Пытливый - 6 Апр 2016 12:42:47
Кому решение нужно - тот пример и рисует.
 
Пытливый, приложил файл.
Заносим дату в столбец А(дата), если это дата из столбца "поставка 1", то пишем 1 в столбец В(№ поставки), если дата из столбца "поставка 2", тогда заносим в столбец В  2.
Надеюсь понятно объяснил.
 
Ща Малыш по имени Виктор придет и всем лещей раздаст
Лень двигатель прогресса, доказано!!!
 
empty28, название темы никудышное: мы все тут знаем, что существует ЕСЛИ(). Предложите новое название, хоть частично раскрывающее суть проблемы - модераторы исправят.
 
Юрий М, поменяйте на это :  

формула ЕСЛИ с перебором значений из диапазона
 
Цитата
empty28 написал:
приложил файл
а где он? и зачем? :) Формула не сработала?
Кому решение нужно - тот пример и рисует.
Страницы: 1
Читают тему (гостей: 1)
Наверх