Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Выбор варианта из таблицы вариантов по номеру зачетки
 
Здравствуйте!
Помогите пожалуйста с данным вопросом, имеется таблица для выбора варианта по двум последним цифрам зачетки, но я не могу вернуть значение строки (номера варианта), если бы присутствовали значения столбцов, а не только строк, то реализовал бы через ВПР или ИНДЕКС, а тут только строки... - затрудняюсь.
Изменено: Lex Backer - 17 Июл 2016 16:49:37
 
=ЕСЛИ(--ПРАВБ(C2);ОСТАТ(ПРАВБ(C2;2);30);30)
 
vikttur, спасибо, но вот вопрос, а через массив никак нельзя? Что бы искал номер последних двух цифр в таблице и возвращал значение варианта.
Изменено: Lex Backer - 17 Июл 2016 17:00:55
 
1. О массиве Вы не спрашивали.
2. Зачем массив, если решается проще?
 
vikttur, думал массивом будет проще сделать, чем вот так
Код
=ЕСЛИ(--ПСТР(C2;7;2)=0;10;ЕСЛИ(ОСТАТ(--ПСТР(C2;7;2);30)=0;30;ОСТАТ(--ПСТР(C2;7;2);30)))
 
Зачем так? Я Вам показал работающую формулу. Куда уж проще?
 
Поиск в массиве
Код
=СУММПРОИЗВ((--ПРАВСИМВ(C2;2)=$I$4:$L$33)*($H$4:$H$33))
 
gling,блин гениально, малость ток добавить, ЕСЛИ на вариант, когда последние две цифры 00 (т.к. выдает 420).
Спасибо!
 
Да не учел. Нужно в таблице пустые ячейки заполнить чем нибудь, пробелом, тире, буквой или числом >99.
 
Lex Backer, объясните непонятливому: какой смысл в доп. вычислениях, в дополнении таблицы, если можно проще? Мазохизм? Издевательство над Excel? В чем причина?
Для проверки "00" достаточно в простую формулу добавить одну ЕСЛИ
Страницы: 1
Читают тему (гостей: 1)
Наверх