Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Исключить определённое число в генераторе случайных чисел
 
Добрый день! Всем привет!

Подскажите пожалуйста как исключить 0 в "СЛЧИС" например в диапазоне (-12;34)?
 
числа целые хотите получать? или любые?
Живи и дай жить..
 
вообще, как исключить определённое число (чтобы оно не выпадало) в генераторе случайных чисел ("СЛЧИС" или "RAND")? пробовали "СЛУЧМЕЖДУ (-15;25)*НЕ(0) не работает
 
по любому - разбить на два интервала
Живи и дай жить..
 
=ЕСЛИ(СЛЧИС()>0,5;СЛУЧМЕЖДУ(-12;-1);СЛУЧМЕЖДУ(1;34))
Живи и дай жить..
 
или разрешить итерации:
a2=ЕСЛИ(A2=0;СЛУЧМЕЖДУ(-12;34);СЛУЧМЕЖДУ(-12;34))

нет, такая формула не гарантирует отсутствие нуля..  
Изменено: Слэн - 20 Июл 2016 15:11:44
Живи и дай жить..
 
=ОСТАТ(ОТБР(СЛЧИС()*40)+16;41)-15
будут сгенерированы числа от -15 до 25 с равной вероятностью, число 0 - не будет генерироваться
 
еще варианты:
=ЕСЛИ(СЛЧИС()<15/40;СЛУЧМЕЖДУ(-15;-1);СЛУЧМЕЖДУ(1;25))

=ИНДЕКС({-15:-14:-13:-12:-11:-10:-9:-8:-7:-6:-5:-4:-3:-2:-1:1:2:3:4:5:6:7:8:9:10:11:12:13:14:15:16:17:18:19:20:21:22:23:24:25};СЛУЧМЕЖДУ(1;40))
 
на примере диапазона от -12 до +34, без нуля
=ОСТАТ(ОТБР(СЛЧИС()*46)+13;47)-12
=ОСТАТ(СЛУЧМЕЖДУ(13;58);47)-12
=ЕСЛИ(СЛЧИС()<12/46;СЛУЧМЕЖДУ(-12;-1);СЛУЧМЕЖДУ(1;34))
Изменено: MCH - 20 Июл 2016 15:33:03
 
SLAN! Спасибо! Очень помог!
 
А МСН, значит, никак не помог?
 
MCH, быстро проверил варианты - всё отлично работает! Респект за науку  - очень полезные приёмы  8) :idea:
Реквизиты для благодарностей — в профиле
Страницы: 1
Читают тему (гостей: 1)
Наверх