Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Сумирование N значений - вычетание N значений
 
Добрый день уважаемые форумчане встала перед мной  нетривиальная задача найти по полю A:A  уникальные значение (Ф.И.О.) которые могут встречаться в таблице  N`ое количество раз, после суммировать выплаты  которые могут встречаться в таблице  N`ое количество раз поле D:D (СУММЫ РУБ.)  после чего вычесть значений сумм С-D и внести в результат в ячейку Е. Все как бы получилось за исключением дублирующий значений в поле Е. Подскажите как можно избавиться от дублирующих значений Е5:Е8 (обведен красным кружком)
Изменено: Виктор C - 23 Июл 2016 16:20:36
 
А как можно определить что это именно дубли?
 
Испробуйте такую конструкцию
Код
=ЕСЛИ(A4=A3;"";СУММЕСЛИ(A:A;A4;D:D)-СУММЕСЛИ(A:A;A4;C:C))
Изменено: gling - 21 Июл 2016 19:02:43
 
Цитата
Виктор C написал: Подскажите как можно
Вариант для ленивых - сводная таблица (см. Приемы), а данные пусть живут без... выкрутасов. ;)
"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
gling, очень элегантное решение , спасибо за науку
Страницы: 1
Читают тему (гостей: 1)
Наверх