Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Сложение по условию
 
Здравствуйте!

Вот пробую разные функции для сложения данных в столбце по нескольким условиям...
Почему не работает формула:
Поиск должен производится: товар- кто продал.....
Код
БДСУММ(Лист1!A1:F17;Лист1!D1;Товар=сводный!C2 И Фамилия=сводный!A2)
Изменено: eagl69 - 13 Сен 2016 17:46:43
 
Цитата
eagl69 написал: функции для сложения данных
Уж не о вариантах ли функций с СУММ вы намекаете?!. ;)
Image 131.png (4.22 КБ)
Изменено: Z - 13 Сен 2016 17:51:55
"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
Что такое в Вашей формуле Товар и Фамилия? Справку по этой функции читали? Там в конце есть пример ее применения
А Вам будет достаточно
Код
=СУММЕСЛИМН(Лист1!$D$2:$D$17;Лист1!$A$2:$A$17;A2;Лист1!$C$2:$C$17;C2)
Согласие есть продукт при полном непротивлении сторон.
 
Уважаемый eagl69, а может попробовать сводной таблицой это сделать.
Наглядней, быстрее, крутить данные можно как угодно.
Пример в файле, просто перетаскивайте поля как хочется.

Понимаю, что может Вам хотелось бы формулой,
но согласитесь - просто есть другой путь который также приводит к результату
и возможно он продуктивнее
 
Всем доброго времени суток.
Нужна помощь, делаю журнал по расходу средств, в котором все расходы будут заноситься в диапазон G24:I36
В таблице P5:Q20 хочу сделать чтобы эти все значения просчитывались автоматически, нашел два варианта решения:
1. Q9 - через формулу СУММЕСЛИ(G28:G40;"Наличные";I28:I40) минус этой формулы является в том, что название статьи нужно прописывать вручную, скажем если она поменялась и это юудет не совсем удобно

2. Q5-Q7 - через формулу БДСУММ($G$23:$I$36;$I$23;P4:P5), минус этой формулы в том, что решение для ячеек ниже я нашел следующее:
=БДСУММ($G$23:$I$36;$I$23;P4:P6)-Q5
=БДСУММ($G$23:$I$36;$I$23;P4:P7)-Q5-Q6

Подскажите как можно еще решить данную задачу, заранее буду благодарен за ответ. (пример в приложении)
 
зачем писать руками когда можно ссылатся на ячейку с наименованием расхода
Код
=СУММЕСЛИ($G$24:$G$36;P5;$I$24:$I$36)
Лень двигатель прогресса, доказано!!!
 
Сергей, спасибо!
Страницы: 1
Читают тему (гостей: 1)
Наверх