Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Умножение значений в строках и суммирование результата, Условие: нужна короткая формула при большом количестве значений
 
Как правильно написать формулу, чтобы была максимально "лаконичной") ?
Есть две строки в обоих строках есть значения.
Условия такие: если в первой строке есть значение больше нуля, то его умножить на соответствующее значение из второй строки и т.д. и в итоге просуммировать перемноженные значения.
Пример прилагается
Заранее благодарю
 
Mordvin111, если во второй строке не будет значений меньше 0
Код
=СУММПРОИЗВ(C2:J2;C4:J4)
 
Чутка не понял. Если в строке 2 значение равно 0, то его произведение с любым числом будет =0, что никак не отразится на сумме.
Однако, если смысл в этом есть, то можно попробовать это:
=СУММ((C2:J2*C4:J4)*(C2:J2>0))
*массива, если что.
 
Спасибо, не знал эту функцию. Выручили всем спасибо!!!
Страницы: 1
Читают тему (гостей: 1)
Наверх