Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Формирование текста и его деление на столбцы
 
Добрый день!
Прошу подсказать, как грамотно и быстро можно "отсортировать" текст в первом столбце для его формирования по в другие последующие столбцы.  
Изменено: dm_pm - 26 Ноя 2016 23:30:18
 
Количество предметов: =ЕСЛИОШИБКА(--ПОДСТАВИТЬ(СЖПРОБЕЛЫ(ПСТР(A2;ПОИСК("предм.";A2)-5;2));"-";"");"")
Цвет: =ЕСЛИОШИБКА(СЖПРОБЕЛЫ(ПСТР(A2;ПОИСК("цвет:";A2)+5;99));"")
Если sv2013 угадал с конечным результатом по названию (см.сообщение ниже), то
Название: =ЕСЛИОШИБКА(ПСТР(A2;ПОИСК("^";ПОДСТАВИТЬ(A2;"""""";"^";1))+2;ПОИСК("^";ПОДСТАВИТЬ(A2;"""""";"^";2))-ПОИСК("^";ПОДСТАВИТЬ(A2;"""""";"^";1))-2);"")
Изменено: Sanja - 27 Ноя 2016 12:42:24
Согласие есть продукт при полном непротивлении сторон.
 
добрый день,не нашел,как Вам надо,вариант функций в столбцах B,C,D  файл-примера
Код
Function uuuu$(t$)
 With CreateObject("VBScript.RegExp"): .Pattern = " \d+(?=-(?:ми|х) предм\.)"
   If .test(t) Then uuuu = .Execute(t)(0) Else uuuu = ""
 End With
End Function
Код
Function vvvv$(t$)
 With CreateObject("VBScript.RegExp"): .Pattern = "цвет:.+$"
   If .test(t) Then vvvv = Mid(.Execute(t)(0), 6) Else vvvv = ""
 End With
End Function
Код
Function yyyy$(t$)
With CreateObject("VBScript.RegExp")
.Pattern = "^\"""
t = .Replace(t, "")
  .Pattern = """(.+)""": .Global = True
   If .test(t) Then yyyy = Replace(.Execute(t)(0).Submatches(0), """", "") Else yyyy = ""
 End With
End Function
Изменено: sv2013 - 27 Ноя 2016 12:15:44
Страницы: 1
Читают тему (гостей: 1)
Наверх