Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Нумерология: цифры вместо букв по таблице
 
Интересная задача возникла для нейминга компании, где клиент пожелал подбор имени соответствующий его сфере. Она решается силой нумерологии, где каждая цифра соответствует определённой планете и любое название несёт соответствующую энергию.

Чтобы рассчитать кодовое число названия фирмы нужно сложить до  однозначного числа все цифры, соответствующие буквам из названия.  
Рассмотрим на примере фирмы под названием «Семья»  воспользовавшись  нашей таблицей.
1  2  3  4  5  6  7  8  9
А  Б  В  Г  Д  Е  Ё  Ж  З
И  Й  К  Л  М  Н  О  П  Р
С  Т  У  Ф  Х  Ц  Ч  Ш  Щ
Ъ  Ы  Ь  Э  Ю  Я      
Например:
С-1, Е-6, М-5, Ь-3, Я-6.  Получаем  1+6+5+3+6=21=2+1=3
Таким образом кодовое число названия фирмы «Семья» равно 3. (что соответствует энергии Юпитера, т.е. всё что связано с обучением, с детьми и благотворительностью).

Теперь задача - как в экселе написать формулу, чтобы по списку названий считалось это конечное число (с учётом суммы двухзначного значения)?
 
Формула в желтой ячейке, проверяйте

PS: формула работает только с кириллицей, нет проверки на недопустимые символы (пробелы, цифры, знаки, латиницу)
Изменено: MCH - 10 Янв 2017 08:20:18
 
MCH,красивая формула, только в алфавите уфхЦчшщ =)
 
Цитата
heso написал:
только в алфавите уфхЦчшщ =)
Опечатку исправил
 
вот это да!
MCH, огромное спасибо, я бы в жизни не догадался как записать такую огромную функцию. браво!!!

а можно ли с английским вариантом что-то сделать?
Number Values for English Alphabets as per Numerology
1= a, i, j, q, y
2= b, k, r
3= c, g, l, s
4= d, m, t
5= e, h, n, x
6= u, v, w
7= o, z
8= f, p
Elephant = 5+3+5+8+5+1+5+4 = 3+6 = 9
Изменено: Aniruddha - 10 Янв 2017 13:20:50
 
Aniruddha, так наверно
Код
=ОСТАТ(СУММПРОИЗВ(ОСТАТ(ПОИСК(ПСТР(A1;СТРОКА(ДВССЫЛ("1:"&ДЛСТР(A1)));1);"abcdeuofikgmhvzpjrltnw  q s x   y")-1;8)+1)-1;9)+1
Изменено: Казанский - 10 Янв 2017 10:03:23
 
Большое спасибо, друзья! Удачи вам и пользуйтесь сами древнейшей системой. Реально работает, проверено. Всем желаю удачи ;-)

p,s, подробнее о значениях числе можно найти например здесь
Изменено: Aniruddha - 10 Янв 2017 11:11:59
 
От единичек можно избавиться.
..." нопрстуфхцчшщъыьэюя")-1;9)+1)-1;9)+1
"..Сладку ягоду рвали вместе, горьку ягоду я одна."
 
Цитата
Владимир написал: От единичек можно избавиться.
думаю, что нельзя
 
MCH, Скажите, пожалуйста, а можно ли как-то видоизменить вашу формулу, чтобы сумма цифр была посчитана только для гласных или согласных букв слова?
 
Цитата
heso  написал:только в алфавите уфхЦчшщ
Цитата
MCH написал:Опечатку исправил

Подскажите, а как нам сократить формулу до общей суммы
В задаче было
Например:
С-1, Е-6, М-5, Ь-3, Я-6.  Получаем  1+6+5+3+6=21=2+1=3

А хотелось бы только до тех пор где сумма получается, то есть:
Например:
С-1, Е-6, М-5, Ь-3, Я-6. Получаем 1+6+5+3+6=21

Чёт методом тыка не выходить, а мозгов не хватает самому преобразовать....
Изменено: petrrusanov - 14 Янв 2020 14:55:12
 
petrrusanov,
Код
=СУММПРОИЗВ(ОСТАТ(ПОИСК(ПСТР(A1;СТРОКА(ДВССЫЛ("1:"&ДЛСТР(A1)));1);
"абвгдеёжзийклмнопрстуфхцчшщъыьэюя")-1;9)+1)
 
Ой спасибо вам огромное!
Страницы: 1
Читают тему (гостей: 1)
Наверх