Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Разместить значения в столбец без пустых ячеек
 
Добрый день дорогие друзья!

Прошу помочь со следующей задачей:
Во вложенном примере, выложены условные значения в столбца от С до Н,
Я не смог выложить уловные значения в столбцы начиная с I, без пустых ячеек,

Пример во вложении,

Спасибо!
 
Формула массива для "I2":
=ЕСЛИОШИБКА(ИНДЕКС($A2:$H2;1;НАИМЕНЬШИЙ(ЕСЛИ($C2:$H2<>"";СТОЛБЕЦ($C2:$H2);"");СТОЛБЕЦ(A$1)));"")
Если первый раз видите формулу массива, то посмотрите в интернете, как ее вставлять.
 
Каратаев! Спасибо большое!
 
Без массивного ввода, но для ексель 2010+.
Код
=IFERROR(INDEX($C2:$H2;;AGGREGATE(15;6;COLUMN($A:$E)/($C2:$H2<>"");COLUMNS($I:I)));"")
 
Спасибо Jakim, тоже метод!
Страницы: 1
Читают тему (гостей: 1)
Наверх