Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Найти сумму за определенный период (формулами)
 
Добрый день, уважаемые форумчане. Помогите пожалуйста формулой или ссылкой на таковую. Нужно найти сумму значений за определенный период. Например найти сумму по Москве с января по июль.
Файл прикладываю.
Премного благодарен всем откликнувшимся.
 
Вариант:
Код
=СУММЕСЛИМН(B2:M2;B1:M1;">="&O5;B1:M1;"<="&O6)
Кому решение нужно - тот пример и рисует.
 
Спасибо большое, буду пробовать.
 
Пытливый не, не подходит, нужно что то более универсальное, чтобы изменить москву на другой регион и оно считало. Так как Вы предложили, в принципе у меня есть решение, немного другое, но принцип тот же.
 
Тогда формулой массива:
Код
=СУММ(ИНДЕКС(B2:M19;ПОИСКПОЗ(O4;A2:A19;0);)*(B1:M1>=O5)*(B1:M1<=O6))
Кому решение нужно - тот пример и рисует.
 
Пытливый Спасибо огромное, буду пробовать.
 
Тоже не подходит, там москвы две, одна в А3, другая в А15. Нужно их все складывать
 
"..врёшь, не возьмёшь!..." :)
Формула массива:
Код
=СУММ((A2:A19=O4)*((B2:M19)*(B1:M1>=O5)*(B1:M1<=O6)))
Кому решение нужно - тот пример и рисует.
 
С функцией СУММРОИЗВ без массивного ввода и с выпадающим списком.
 
Спасибо всем огромное. Как всегда выручили  :)
Изменено: alexthegreat - 7 Фев 2017 17:17:24
Страницы: 1
Читают тему (гостей: 1)
Наверх