Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
В формуле использовано: ЕСЛИ, ЕНД, ВПР. Нужно заменить Н/Д на ноль.
 
Excel 2007.
Привожу рабочую формулу полностью:
=ЕСЛИ(ЕНД(ВПР(B12;Завтрак_табл;2;0));ЕСЛИ(ЕНД(ВПР(B12;Перекус_табл;2;0));ЕСЛИ(ЕНД(ВПР(B12;Обед_табл;2;0));ЕСЛИ(ЕНД(ВПР(B12;Ужин_табл;2;0));ЕСЛИ(ЕНД(ВПР(B12;Десерт_табл;2;0));ВПР(B12;Гарнир_таб;2;0);ВПР(B12;Десерт_табл;2;0));ВПР(B12;Ужин_табл;2;0));ВПР(B12;Обед_табл;2;0));ВПР(B12;Перекус_табл;2;0));ВПР(B12;Завтрак_табл;2;0))*I12

Задача: вместо Н/Д заставить писать 0.  
 
Вариант добавить в самом начале функцию ЕСЛИОШИБКА не работает? То есть вот так:

=ЕСЛИОШИБКА(ЕСЛИ(ЕНД(ВПР(B12;Завтрак_табл;2;0));ЕСЛИ(ЕНД(ВПР(B12;Перекус_табл;2;0));ЕСЛИ(ЕНД(ВПР(B12;Обед_табл;2;0));ЕСЛИ(ЕНД(ВПР(B12;Ужин_табл;2;0));ЕСЛИ(ЕНД(ВПР(B12;Десерт_табл;2;0));ВПР(B12;Гарнир_таб;2;0);ВПР(B12;Десерт_табл;2;0));ВПР(B12;Ужин_табл;2;0));ВПР(B12;Обед_табл;2;0));ВПР(B12;Перекус_табл;2;0));ВПР(B12;Завтрак_табл;2;0))*I12;"")

И нулей не будет, не надо будет закрашивать.

А если что-то нужно закрасить - условное форматирование, если в ячейке "0", то цвет шрифта - белый. Вот здесь расписано, как и что: http://www.planetaexcel.ru/techniques/9/70/
 
Оберните вашу формулу функцией ЕСЛИОШИБКА().
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Да, заработало! Спасибо вам огромное!
Взялся с дуру сделать калькулятор хорошим людям, не ожидал такого сопротивления науки) Чтобы родить эту чудо-формулу пришлось несколько раз переделывать и 4 дня курить гугл.  
 
Может чудо-формулу можно и упростить ;).
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Возможно, если из таблиц "Завтрак_табл", "Перекус_табл", "Обед_табл", "Ужин_табл", "Десерт_табл", Гарнир_табл" сделать одну. Кстати, а для чего такая разбивка понадобилась? Собрать калории в одну таблицу в качестве способа решения не подходит?
 
Сводная таблица почему-то вообще никакая выходит из всего этого. Ну, то есть не собирается ничего внятного.
В каждой таблице ещё и столбец блюд есть - отсюда и разбивка. Для удобства использования.
И да, чудо-формулу можно и упростить, но, боюсь, на поиск более изящного решения уйдет не меньше времени. Я ведь дуб в экселе, как оказалось, полный)

 
Страницы: 1
Читают тему (гостей: 1)
Наверх