Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Поиск последующих совпадений одинаковых ячеек
 
Добрый Вечер, Уважаемые Форумчане!
Почитал в форумах подобные проблемы, но либо не понял, либо не то... Один пример с формулой =ВПР2 ваще с ума свел, там ведь и макроса не нашел...

Короче, есть файл (во вложении), там есть 2 таблицы, одинаковые в принципе. Когда пытаюсь заполнить вторую значениями первой, то для повторяющихся наименований берется значение первой... Через поискпоз и ктрл+шифт+ентер пробовал, думал может поможет.. нет, никак!
Помогите!!
Чайникам куда труднее, чем кажется!!
 
Подходит? обратите внимание формула массива.
 
Dante132, здравствуйте! обратите внимание, что в рабочем столбце порядок перечня другой. В вашем примере Зеленые арбузы = 12, а должно быть 152. красные арбузы = 2, а должно быть 7... и тд.
Чайникам куда труднее, чем кажется!!
 
дополнительным столбцом задаете уникальность продукта а потом уже сравниваете и переносите что надо ВПР
Лень двигатель прогресса, доказано!!!
 
да забыл предупредить это будет работать если данные в двух таблицах по категории идут в одинаковом порядке, елс будет пересортица и будете работать только с цифрами то  вот вариант с
Код
=СУММЕСЛИМН($D$2:$D$13;$A$2:$A$13;H2;$C$2:$C$13;J2)
Лень двигатель прогресса, доказано!!!
Страницы: 1
Читают тему (гостей: 1)