Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Мгновенное изменение значения в ячейке в зависимости от значения в соседней ячейке, ячейка, проверка на пустоту в ячейке
 
Доброго дня!
Прошу помощи уважаемых форумчан в следующем вопросе:
В приложенном файле  на листе 1 есть выпадающий список (выделен желтым).
В столбце R есть формула:
Цитата
=ЕСЛИ(ЕПУСТО(A1);"";"экз.")
Она проверяет, пустая ли ячейка слева и, в зависимости от результата, пишет "экз." или ничего не пишет.
Но вот незадача в том, что формула не работает оперативно, т.е если я удаляю текст из желтого столбца (делаю ячейку пустой) то в ячейке с формулой "экз" продолжает отображаться, и нужно закрыть файл с сохранением, потом его снова открыть и тогда вместо "экз" будет пусто.
Вопрос: нельзя ли как нибудь сделать так, чтобы при изменении в желтом столбце (есть текст - нет текста) столбец R с формулой реагировал мгновенно?
Спасибо.
 
включите автоматический пересчет формул вкладка ФОРМУЛЫ, кнопка ПАРАМЕТРЫ ВЫЧИСЛЕНИЙ выбрать автоматически
Лень двигатель прогресса, доказано!!!
 
У вас установлено вычисление формул вручную. Поменяйте на автоматически.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Цитата
john22255 написал: нельзя ли как нибудь сделать
А у вас авто пересчет формул включен?!. ;)
"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
Цитата
Сергей написал:
включите
Цитата
Bema написал:
Поменяйте
Цитата
Z написал:
пересчет формул
Большое спасибо всем откликнувшимся! Все заработало.
Страницы: 1
Читают тему (гостей: 1)
Наверх