Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
У всех эксель неправильно высчитывает количество месяцев от июля до декабря?
 
Собственно приложение
 
Код
=МЕСЯЦ($C$2)-МЕСЯЦ(B2)
Согласие есть продукт при полном непротивлении сторон.
 
SanJa..... он мне 5 выдаёт вместо 6...
 
А почему Вы 6 ждете? ПОЛНЫХ месяцев - 5
Согласие есть продукт при полном непротивлении сторон.
 
Код
=РАЗНДАТ(B2;C2;"m")
 
Если считать по формулам, которые я применяла, то он считает как раз так, как мне нужно все даты, за исключением этого июля....Мне надо амортизацию рассчитывать Если оборудование введено 1 мая, то надо вычесть из декабря май, чтобы узнать сколько месяцев оно эксплуатировалось. Всё было отлично, но на этом июле свет клином сошёлся.  
 
Разндат тут не катит - тоже не то выдаёт. Тут ещё загвоздка, иногда даты по столбцу B превышают дату C. Так что разндат тут точно не справится.  
 
Цитата
разндат тут точно не справится.
Так примените функцию ЕСЛИ
 
РАЗНДАТ считает не то, что нужно. Он считает полные месяцы. А мне надо включительно с 1 мая по 31 декабря: 8 месяцев, РАЗНДАТ покажет только 7
 
Доброе время суток!
Алгоритм дайте, пжл.
Если объект вводится в эксплуатацию 15/03,
что мы должны иметь 31/12?
Если для Вас принципиальны встроенные
функции, то, думаю, Вам поможет КОНМЕСЯЦА!!!
Удачи!
 
Спасибо всем за ответы.

Объект вводится всегда с 1 числа.
Если объект вводится 1 января, то к 31 декабря амортизация должна начисляться  за 12 месяцев. Если с 1 июня - то за 7 месяцев. По приведённой мной формуле считает все месяцы правильно. Все, кроме июля. Excel считает что и от 1 июня и от 1 июля до 31 декабря проходит 7 месяцев. Амортизацию нужно начислять с первого числа месяца, когда оборудование принято к учёту. РАЗНДАТ нам даёт только полные месяцы. Это не то.  
 
Поясните, как использовать функцию конмесяца? Если я правильно понимаю, то она служит для того, чтобы вычислить дату.  
 
Цитата
All345 написал: Мне надо амортизацию рассчитывать
Однако:
- https://www.google.com/search?q=%D0%B0%D0%BC%D0%BE%D1%80%D1%82%D0%B8%D0%B7%D0%B0%D1%86%D0%­B8%D1%8E+%...
- https://www.google.com/search?q=%D0%B0%D0%BC%D0%BE%D1%80%D1%82%D0%B8%D0%B7%D0%B0%D1%86%D0%­B8%D1%8E+%...
Изменено: Z - 18 Фев 2017 09:48:19
"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
а так  
 
Неразумно ожидать нужный результат, используя функцию не по назначению.
Месяц
Цитата
Возвращает месяц для даты, заданной в числовом формате
То есть вычитая из одной даты другую и скармливая это ф-ции МЕСЯЦ - вы получаете месяц для дат 1900 года.
Изменено: Dima S - 18 Фев 2017 17:29:29
 
количество дней с 01.01.1900 Сообщение #2
Согласие есть продукт при полном непротивлении сторон.
 
если так:
Код
=ОКРУГЛ(ДНЕЙ360(B2;$C$2)/30;0)
но нужно понимать что что при таком округлении первая половина июля будет давать 6й месяц, но со второй половины июля уже 5 месяцев.
аналогично и со всеми иными месяцами.
 
Попробуй использовать
=МЕСЯЦ($C$2)-МЕСЯЦ(B3)+1
 
Valera2, у нас на форуме к незнакомым людям принято обращаться на Вы.
 
Еще наткнулся на вариант.
Код
=ДОЛЯГОДА(B2;C2)*12
Страницы: 1
Читают тему (гостей: 1)