Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Посчитать сумму по 3 столбцам с выборам значений и условий
 
Дорого времени суток !!! Нужно до 20 сделать отчет, а с формулой беда!!!
Нужно посчитать C13 в столбце К выбрать "НВГ", в столбце L выбрать "адм" в столбце J выбрать > 365 и посчитать сумму столбца М
 
apraksm, проверяйте.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Но почему ноль в ответе а должно быть 2
 
Код
=SUMIFS(M4:M6;K4:K6;"НВГ";L4:L6;"адм";J4:J6;">365")
Изменено: БМВ - 18 Фев 2017 20:10:52
 
А почему 2? У нас три условия: НВГ, адм и >365. Суммируем столбец М. В вашем примере эти 3 условия не выполняются одновременно. Или я чего-то не понял?
БМВ, здравствуйте. Как оказалось не все так просто :).
Изменено: Bema - 18 Фев 2017 20:11:44
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Нужно считать сумму только тех 1 в столбце М которые соответствуют условиям "НВГ" "АДМ" и ">365"  
 
apraksm, так формула это и считает. В вашем примере эти 3 условия не выполняются.
Изменено: Bema - 18 Фев 2017 20:15:15
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
apraksm,  точнее не выполняется всего одно ">365". Два человека независимо поняли одинаково. Значит не так пояснили.
 
СПАСИБО!!! нашел ошибку!!!! буду пробовать!
 
Ну вот и чудно.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
начал применять к рабочей таблице выдает ошибку может потому что отчет у меня на втором листе
=общий!СУММЕСЛИМН(X3:X752;M3:M752;"НВГ";W3:W752;"адм";K3:K752;">365")
 
Ну конечно. Если принять, что ваша исходная таблица на листе общий!, а сумму хотите получить на другом листе, то формула будет выглядеть так:
=СУММЕСЛИМН(общий!X3:X752;общий!M3:M752;"НВГ";общий!W3:W752;"адм";общий!K3:K752;">365")
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Вышла такая проблема! После добавления 8 формулы в отчете, результат в первых формулах меняется на #ЗНАЧ!
Изменено: apraksm - 18 Фев 2017 21:43:40
 
apraksm, Вы не рассказывайте, а показывайте. В Excel-файле )
 
может есть предел в количествах формул?
 
Цитата
Ошибка #ЗНАЧ! в Excel означает: "Формула вводится неправильно. Или что-то не так с ячейками, на которые указывают ссылки".
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
скрытые ячейки могут быть проблемой?
Изменено: apraksm - 18 Фев 2017 22:16:35
 
А отобразить их и проверить?
 
А как сделать чтобы диапазон добавлялся сам по мере добавления строк в этой формуле
=СУММЕСЛИМН(общий!$X3:$X$800;общий!$M3:$M$800;"НВГ";общий!$W3:$W$800;"адм";общий!$K3:$K$800;"<365")

так называемый Динамический диапазон
Изменено: apraksm - 19 Фев 2017 14:33:46
 
Нашел решение!!!! =СУММЕСЛИМН(общий!$AC:$AC;общий!$M:$M;"НВГ";общий!$AB:$AB;"адм";общий!$K:$K;"<365")
Страницы: 1
Читают тему (гостей: 1)
Наверх