Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Как найти нужные символы в тексте
 
Подскажите пожалуйста, как найти в тексте (в одной ячейки) нужные значения. Т.е. если в конкретной ячейки имеются определенные значения (цифры или буквы), то условие не выполняется. Во вложении есть пример задания.
 
Формула массива для "B1" (редактирование (ввод формулы) завершать не как обычно - нажатием на Enter, а Ctrl+Sift+Enter):
=ЕСЛИ(СЧЁТ(НАЙТИ(A4:A7;A1));"не выполняется";"выполняется")
Искомые символы я вставил в A4:A7.

Если искомых символов немного, то символы можно записать прямо в формулу:
=ЕСЛИ(СЧЁТ(НАЙТИ({2:"A":3:9};A1));"не выполняется";"выполняется")

Для функции НАЙТИ большая и маленькая буква разные буквы. Например, А<>а. Если для Вашей задачи А=а, то используйте функцию ПОИСК.
Изменено: Karataev - 19 Фев 2017 15:43:07
 
массивная
Код
=NOT(COUNTIF(A1;{"*2*";"*A*";"*3*";"*9*"}))
не массивная
Код
=SUMPRODUCT(IFERROR(FIND({"2";"A";"3";"9"};A1);0))=0
Изменено: БМВ - 19 Фев 2017 15:58:22
 
Большое спасибо, все получилось )
Страницы: 1
Читают тему (гостей: 1)
Наверх