Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Функции "Счетзаливка" и диапазоны несмежных ячеек
 
Добрый день!

Подскажите, пожалуйста, как работать с диапазонами несмежных ячеек при использовании функций? К примеру, имеется функция для подсчета кол-ва ячеек по цвету заливки:
Код
Public Function СЧЁТЗАЛИВКА(ДИАПАЗОН As Range, ЯЧЕЙКА) As Long
    Dim S As Double
    Dim rCell As Range
    Dim ColCell As Long
  
    ColCell = ЯЧЕЙКА.Interior.Color
    S = 0
  
    For Each rCell In ДИАПАЗОН
        If rCell.Interior.Color = ColCell Then
            S = S + 1
        End If
    Next
  
    СЧЁТЗАЛИВКА = S
End Function


Каким образом можно использовать эту функцию, если диапазон состоит из несмежных ячеек? Можно, конечно, суммировать кучу функций: =СЧЁТЗАЛИВКА(диапазон1;критерий)+СЧЁТЗАЛИВКА(диапазон2;критерий)+СЧЁТЗАЛИВКА(диапазон3;критерий) и т.д. Но это очень долго и трудоемко!

Помогите, пожалуйста, адаптировать функцию для работы с несмежными ячейками  :sceptic:
Excel 2010
 
Application.Union ?
http://www.planetaexcel.ru/forum/index.php?PAGE_NAME=message&FID=1&TID=87980
 
Ну то, что первое в голову пришло - Выделить этот несмежный диапазон, присвоить ему Имя, а уже его (Имя) использовать в формуле
Согласие есть продукт при полном непротивлении сторон.
 
Все просто - указывайте эти диапазоны в скобках:
=СЧЁТЗАЛИВКА((A3:A4;A7:A9;A11);A3)
Даже самый простой вопрос можно превратить в огромную проблему. Достаточно не уметь формулировать вопросы...
 
Спасибо, со скобками работает!  :) @Sanja Именной диапазон тоже как вариант, однако он почему-то не работает с функцией СЧЁТЕСЛИ.

Мне нужно также посчитать кол-во несмежных ячеек (напр. A1, A3, A5) по критерию ">0", но функция СЧЕТЕСЛИ не работает. Формулу вводил так: =СЧЁТЕСЛИ((A1;A3;A5);">0")  
Excel 2010
 
Методы выполнения подсчетов на листе
Согласие есть продукт при полном непротивлении сторон.
 
Там, к сожалению, нет описания функции для подсчета несмежных ячеек по нужному критерию  :(
Excel 2010
 
Цитата
Eugen_excel написал:
Мне нужно также посчитать кол-во несмежных ячеек (напр. A1, A3, A5) по критерию ">0", но функция СЧЕТЕСЛИ не работает. Формулу вводил так: =СЧЁТЕСЛИ((A1;A3;A5);">0")
Все оказалось очень просто.
Функция будет такой: =СУММ(A1>0;A3>0;A5>0)  8) Ответ нашел тут.
Excel 2010
Страницы: 1
Читают тему (гостей: 1)