Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
выпадающий список с автоматическим заполнением соседней ячейки
 
Доброго дня!
Я уже спрашивал о подобных конструкциях, но тут другое дело:
На Лист1 объединенная ячейка (подсвечена желтым), в которой выпадающий список (расположенный на Лист 2 в о втором столбце). А в третьем столбце на Лист2 еще один список, строки из которого должны автоматически вставляться в синюю ячейку на Лист1, при выборе какой либо позиции из выпадающего списка в желтой ячейке.
По совету Уважаемых форумчан вставляю в синюю ячейку такой код:
Код
=ЕСЛИОШИБКА(ВПР(RC[-22];Лист2!R2C2:R11C3;3;ЛОЖЬ);"")
Но ожидаемого эффекта нет - в синей ячейке ничего не появляется.
Прошу подсказать, что я делаю не так?
Спасибо.
Изменено: john22255 - 20 Фев 2017 09:26:02
 
=IFERROR(VLOOKUP(C2;Лист2!$B$2:$C$11;2;FALSE);"")
исправьте 3 на 2
 
У вас ошибка по синтаксису ВПР. Вы задаете диапазон, где будете искать искомое значение, а потом выводить нужные из  заданного столбца - в 2 столбца и 10 строк, а в формуле указываете выводить столбец №3. Откуда столбец 3 брать - непонятно, формула паникуэ.... :) и выдает ошибку. А ЕСЛИОШИБКА мужественно обрабатывает ошибку и выдает пустое значение.
Кому решение нужно - тот пример и рисует.
 
Цитата
skais675 написал:
исправьте
Цитата
Пытливый написал:
У вас ошибка
Большое спасибо.Все заработало. А я думал что столбец-то третий с начала (на лист2) вот и следует писать "3". :oops:
 
john22255 -
Цитата
john22255 написал:
А я думал что столбец-то третий с начала (на лист2) вот и следует писать "3".
Вы же задали диапазон не сначала а с колонки B.
Страницы: 1
Читают тему (гостей: 1)
Наверх