Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Количество строк состоящих в диапазоне дат и времени
 
Добрый день.
Подскажите как посчитать кол-во сообщений, которые входят в диапазон дат и времени.
Конкретно на примере (во вложении) необходимо посчитать кол-во сообщений на листе 1 которые были в диапазоне от 13.02.2017 (столбец К) 20:00 (столбец L) до 17.02.2017 (столбец M) 20:00 (столбец N). На листе 2 предполагается расчёт в ячейке залитой желтым цветом. Даты для условия из листа 1.
При попытках найти ответ на форуме, допустил крах.
Пользуюсь Excel 2010.
Заранее благодарен за любую помощь.
 
результат не проверял
Код
=СУММПРОИЗВ(('Лист 1'!K2:K330+'Лист 1'!L2:L330>=A2+B2)*('Лист 1'!M2:M330+'Лист 1'!N2:N330<=C2+D2))
Лень двигатель прогресса, доказано!!!
 
Спасибо за помощь, но не считает. На листе 1, есть сообщения с пустой ячейкой даты окончания (сообщение не закрыто и не имеет даты окончания), но в диапазон условия попадает. Формула этого не видит к сожалению.
 
стартовое сообщение перечитайте где там хоть намек на
Цитата
Lostik написал:
сообщение не закрыто и не имеет даты окончания)
Код
=СУММПРОИЗВ(('Лист 1'!K2:K330+'Лист 1'!L2:L330>=A2+B2)*('Лист 1'!M2:M330+'Лист 1'!N2:N330<=C2+D2)*НЕ(ЕПУСТО('Лист 1'!M2:M330)))
Лень двигатель прогресса, доказано!!!
 
Проблема не в том что было или нет в условии. Самое главное условие - это диапазон от и до, то есть если у нас попадаются сообщения с датой начала 12.03.2016 по 14.02.2017 или с датой окончания "Пусто", то эти сообщения попадают под условие 13.02.2017 (столбец К) 20:00 (столбец L) до 17.02.2017 (столбец M) 20:00 (столбец N). В случае вашей формулы, ячейки с датой окончания "пусто" в обоих случаях формула игнорирует, даже если заполнить пустые ячейки текущей датой, что все равно попадает в условие, но увы их формула в учет не берет.
Спасибо за помощь.
 
желаемый результат в файле покажите и еще раз поясните почему так а не подругому
Лень двигатель прогресса, доказано!!!
 
Формула видит сообщения как-то выборочно, должно получиться 329 сообщений, при двух формулах ни разу такого значения не показало.
Изменено: Lostik - 20 Фев 2017 12:16:52
 
каким боком должно получится 329 у вас всего анализируемых записей 329 и по ним вы задаете условие т.е часть отсекаете из подсчета вы уж сами определитесь что хотите
Лень двигатель прогресса, доказано!!!
 
В данном примере под условие попадают все 329 (это просто пример). Все сообщения во временном промежутке заданного условия.
 
Цитата
Lostik написал:
под условие попадают все 329
да ну берем первую строку столбец К = 01.03.2015 как эту дату впихнуть в рамки данного условия
Цитата
Lostik написал:
13.02.2017 (столбец К) 20:00 (столбец L) до 17.02.2017 (столбец M) 20:00 (столбец N)
из темы ушел, учитесь формулировать мысли
Лень двигатель прогресса, доказано!!!
Страницы: 1
Читают тему (гостей: 1)