Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Отображение цены выбранного товара из другой таблицы, работает коректно только на первых 6 строках
 
Есть два листа Прайс и Счет. В прайсе в две колонки размещены товар и его цена. На листе Счет с выпадающего списка выбираем товар а цена подтягивается по формуле:

=IF(ISNA(VLOOKUP(A1;Прайс!A1:D108;2;FALSE));"";VLOOKUP(A1;Прайс!A1:D108;2;FALSE))

Но начиная с 7 строки в Счете цена для позиций Груша1-Груша13 (возможно еще какие-то, я не проверял), не отображается.
Подскажите в чем проблема.
Если знаете альтернативный способ реализации данного функционала - буду весьма благодарен.
 
Вы в диапазоне $ доллар забыли. Закрепите диапазоны.
Код
=ВПР(A1;Прайс!A$1:B$108;2;ЛОЖЬ)
Изменено: Caho - 20 Фев 2017 13:12:31
Никаких врагов, зато и никаких друзей.
 
Caho,Спасибо. Заработало)
Страницы: 1
Читают тему (гостей: 1)
Наверх