Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Как подтянуть цены в столбец, из разных листов и таблиц на листах
 
Здравствуйте.
Никак не могу понять и найти решение.
Задача:
есть несколько листов(в примере Stels, Merida), в каждом листе есть несколько таблиц, записанных в ряд.
Каждая табличка содержит уникальные артикулы, цену закупки и розничную цену.

Есть сводный лист, в примере он называется "Список", где в столбик записаны артикулы, и к ним нужно подтянуть цены из столбца "Розница" со всех листов.

С помощью ВПР получилось через диапазоны на каждую табличку и кучу ЕСЛИ(проверяющего бренд) - очень громоздко и, при наличии 30-40 брендов, по-моему закончится допустимая длина формулы.

Можно ли сделать, чтобы цены подтягивались не зависимо от количества листов и строк в таблицах?
Ну или с ограниченным количеством листов, которое можно изменить, т.к. это происходит редко.

Помогите плиз.
Изменено: Svarg - 20 Фев 2017 13:40:22
 
если расположить в столбец на листах поиска то вариант с впр+двссыл
 
Цитата
Vik_tor написал:
если расположить в столбец на листах поиска то вариант с впр+двссыл
Для работы потом невменяемо будет очень... десяток типов листать вниз.
При текущем расположении никак?
 
Ну можно при текущем расположении через пачку ВПР и пачку ЕСЛИ допустим. Но это же неудобно.
 
Цитата
HUB107 написал:
Ну можно при текущем расположении через пачку ВПР и пачку ЕСЛИ допустим. Но это же неудобно.
Я в первом посте написал что так получилось и да, не удобно =) Но, похоже, пока придется сделать так...
а можно как-то сделать массив диапазонов имен?
То есть каждую табличку на листе засунуть в диапазон отдельный, и все эти диапазоны как-то объединить для поиска по ним.
К примеру, если Бренд указан Merida, ВПР искал во всех диапазонах имен (Merida_hard, Merida_dvuh, Merida_***). Формат же одинаковый, искать в одних и тех же столбцах
Изменено: Svarg - 20 Фев 2017 14:07:58
 
пробуйте, проверяйте
Код
=ИНДЕКС(ДВССЫЛ($A2&"!A3:K23");ПОИСКПОЗ($B2;ИНДЕКС(ДВССЫЛ($A2&"!A3:K23");;МАКС(--(ДВССЫЛ($A2&"!A3:K23")=B2)*СТОЛБЕЦ(A1:K1)));0);МАКС(--(ДВССЫЛ($A2&"!A3:K23")=B2)*СТОЛБЕЦ(A1:K1))+2)
Лень двигатель прогресса, доказано!!!
 
Цитата
Сергей написал:
пробуйте, проверяйтеКод ? 1=ИНДЕКС(ДВССЫЛ($A2&"!A3:K23");ПОИСКПОЗ($B2;ИНДЕКС(ДВССЫЛ($A2&"!A3:K23");;МАКС(--(ДВССЫЛ($A2&"!A3:K23")=B2)*СТОЛБЕЦ(A1:K1)));0);МАКС(--(ДВССЫЛ($A2&"!A3:K23")=B2)*СТОЛБЕЦ(A1:K1))+2)
Цитата
Сергей написал:
пробуйте, проверяйте
Спасибо огромное! Работает.. осталось понять как =)
Щас буду разбираться.
 
Svarg, попробуйте в следующий раз обойтись без цитирования: кнопка цитирования не для ответа!
 
Хорошо, извиняюсь.
 
С формулой разобрался все супер.
А такой вопрос к формуле, если название листа с пробелом, например Schwinn Town. Как это подсунуть в ДВССЫЛ($A2&"!A3:X100")?
Выдает ошибку, это можно учесть или проще слепить в 1 слово?
 
А все, разобрался... куча кавычек решает проблему
ДВССЫЛ("'" & A2 & "'!A3:X100")
Страницы: 1
Читают тему (гостей: 1)
Наверх