Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Среднее значение 12 максимальных чисел., Среднее значение 12 максимальных чисел.
 
Добрый день. Подскажите как можно найти среднее значение 12 максимальных чисел из диапазона.
 
Еще не со всеми функциями познакомились?!. ;)
Код
=СРЗНАЧЕСЛИМН($C$4:$C$36;$C$4:$C$36;">="&НАИБОЛЬШИЙ($C$4:$C$36;12))
"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
Проверил, работает, безмерно благодарю ;) ! Не знаком еще с очень многим, спасибо что помогаете!
 
Есть такой вариант.
Код
=СУММПРОИЗВ(--НАИБОЛЬШИЙ($C$4:$C$36;СТРОКА(1:12)))/12

Z, если предположить что все числа в столбце будут одинаково большими, т.е. равны, то среднее по Вашей формуле будет определяться не правильно. В файле это видно.

Изменено: gling - 20 Фев 2017 19:09:39
 
...
Изменено: gling - 20 Фев 2017 19:12:48 (Ответ продублировал случайно.)
 
Цитата
gling написал: если предположить что...
OFF Виноват - поленился сделать как всегда, для страховки, свою приписку - "Как вариант, однако... ;)". Учтем на будущее.
"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
Предлагаю такую формулу
Код
=СУММ(НАИБОЛЬШИЙ(C4:C36;{1;2;3;4;5;6;7;8;9;10;11;12}))/12
Страницы: 1
Читают тему (гостей: 1)