Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
поиск и выборочное суммирование ячеек
 
Доброе время суток. Дана таблица с часами работ сотрудников. На первом листе заполняется время прихода и ухода сотрудника, сколько отработано часов за день.
На втором листе нужно посчитать кол-во отработанных часов за интервал из первого листа для каждого сотрудника.

Пробовал использовать СУММЕСЛИ, но не получилось.  
Изменено: bingotlt - 21 Фев 2017 10:18:59
 
А что именно не получилось? Там, вроде, все просто:
Код
=СУММЕСЛИ('Часы работ'!B2:B10;'Сумма за месяц'!B4;'Часы работ'!E2:E10)

формат ячейки задать [ч]:мм:сс
Кому решение нужно - тот пример и рисует.
 
*del
Изменено: bingotlt - 21 Фев 2017 13:12:36
 
Формула почему то не суммирует время. Берет значение из последней найденной ячейки.
 
Цитата
bingotlt написал: Формула почему то не
Как вы формулу напишите, так она и... ;)
"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
Да вот вся засада, что бы не считать сумму за n-дней для одно сотрудника (т.к. сотрудников около 50)

Нужно что бы из списка всех сотрудников (столбец №2) был выбран сотрудникX (имя сотрудника выбирается из одной любой ячейки с его именем), а из столбца 5 (всего столбца) просумировались ячейки которые совпадают с сотрудникомX.
т.е. =СУММЕСЛИ('Сумма за месяц'!R[-2]C[-1]:R[6]C[-1];RC[-1];'Часы работ'!R[-2]C[2]:R[6]C[2]) выбирает только последнюю совпадающую ячейку, но не суммирует!

Ну и соответственно в листе сумма за месяц, что бы можно было растянуть формулу для всех сотрудников.
Изменено: bingotlt - 22 Фев 2017 08:30:04
 
показывайте в файле что не получается и руками рядом нарисуйте результат какой ожидаете увидеть после работы формулы
Лень двигатель прогресса, доказано!!!
 
Изменено: bingotlt - 22 Фев 2017 09:00:29
 
вот зачем вы картинку нафига она нужна у всех кто тут в теме отписался у всех нормально работает формула, только у вас косяки в ней я для этого и
Цитата
Сергей написал:
показывайте в файле что не получается
Лень двигатель прогресса, доказано!!!
 
bingotlt, вроде бы не тяпница и даже не понедельник, а у вас непонятные заморочки... Вы файл из #5 открывали, прежде чем форумчан мурыжить, - там и умная таблица, и формулы, и скрин?!. ;)
Изменено: Z - 22 Фев 2017 09:21:00
"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
Да вот потому что человек посчитал сумму по столбцам для одного сотрудника в отдельной ячейке....

 
ФАЙЛ ЭКСЕЛЬ НУЖЕН чтоб ВАМ поправить в нем и чтоб вы увидели свою ошибку, формуле диапазон критерия и диапазон суммирования НУЖНО ЗАКРЕПЛЯТЬ
Лень двигатель прогресса, доказано!!!
 
Разобрался.
Вся проблема была в формате. Нужно было выбрать [ч]:мм:сс для ячейки где будет сумма.
 
Цитата
bingotlt написал:
Нужно было выбрать [ч]:мм:сс
во втором сообщении в вашей теме
Цитата
Пытливый написал:
формат ячейки задать [ч]:мм:сс
Лень двигатель прогресса, доказано!!!
 
Хорошо, извиняюсь за невнимательность. А как сделать что бы поиск был не точный, а по совпадению?
Например в ячейки "Бригада1 Сотрудник1" а найти нужно только  "Сотрудник1" ?
Изменено: bingotlt - 22 Фев 2017 09:42:39
 
Еще какие козыри в рукаве есть?
Показываете все возможные варианты в файле-примере, мы на основании данных примера решение придумываем. А то в одном месте у вас Бригада Сотрудник, в другом Сотрудник Бригада, в третьем Сотрудник Начальник бригада....
Кому решение нужно - тот пример и рисует.
 
Файл прикрепил....
Заметил еще один нюанс. Если в формуле выбирать не ячейки, а столбцы, то поиск как раз и идет по последнему найденному значению....
Изменено: bingotlt - 22 Фев 2017 10:06:38
 
переподкрепите файл сейчас он битый
Лень двигатель прогресса, доказано!!!
 
Он не битый. Нажимайте ДА в появившимся окошке. Это программа выдает отчет который так открывается.  
Изменено: bingotlt - 22 Фев 2017 10:25:33
 
+1 за "битый".
Кому решение нужно - тот пример и рисует.
 
Прикрепил.
 
Не, отставить.
Думаю.
Изменено: Пытливый - 22 Фев 2017 11:01:17
Кому решение нужно - тот пример и рисует.
 
Придумал:
Код
=СУММ(ЕСЛИОШИБКА((ЕЧИСЛО(Лист1!$I$1:$I$79)*(Лист1!$I$1:$I$79));0)*ЕСЛИ(ЕСЛИОШИБКА(ПОИСК(Лист2!B10;Лист1!$B$1:$B$79);0)>0;1;0))

формула массива. Вводить через Ctrl+Shift+Enter
Кому решение нужно - тот пример и рисует.
 
формула массива для примера с 21 сообщения посчитает время по Крокус 1
Код
=СУММ((ЕСЛИОШИБКА(ЛЕВСИМВ(Лист1!B1:B79;ПОИСК("-";Лист1!B1:B79)-2);"ъ")=ЛЕВСИМВ(B6;ПОИСК("-";B6)-2))*Лист1!I1:I79)
Лень двигатель прогресса, доказано!!!
Страницы: 1
Читают тему (гостей: 1)
Наверх