Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
При пвторе наименования подтянуть код продукта без макросов
 
Доброе утро.

Есть две таблицы, нужно из одной таблицы подтянуть код продукта в другую. Но проблема в том, что наименование товара может повторяться.
Можно ли вообще как то подтянуть без макросов? Или надо все таки менять наименование товара в базе?

Пример таблицы во вложении.
Спасибо.
 
а зачем это делать ведь в первой таблице код присвоен по трем признакам а во второй всего два признака, подтянуть можно но что это вам дасст
Лень двигатель прогресса, доказано!!!
 
Сергей,

Смысл в том что таблиц много и они между собой связываются, просто ошибка именно в этом месте.
На второй лист нельзя из базы выгрузить ничего более что есть в первом листе и наоборот.
 
не вижу смысла указания разных кодов для одинаковых названий когда присутствует признак который указывает на их отличие, ну да ладно вам видней
формула массива в С2 и тянем вниз
Код
=ИНДЕКС(Лист1!$C$2:$C$9;НАИМЕНЬШИЙ(ЕСЛИ(Лист1!$A$2:$A$9&Лист1!$B$2:$B$9=A2&B2;СТРОКА($1:$8));СУММПРОИЗВ(--($A$2:A2&$B$2:B2=A2&B2))))
Лень двигатель прогресса, доказано!!!
 
Сергей, спасибо за формулу, правильно я понимаю работу формулы:
сначала он подтянет первое встретившееся значение, потом последующее?
как изменить название темы? не могу найти(((
 
Сергей, а еще вопрос:
в формуле СТРОКА($1:$8) - это верно? у меня ведь 9 строк.
 
ну а в формуле то обрабатываем диапазон Лист1!$C$2:$C$9 а он имеет всего 8 позиций
Лень двигатель прогресса, доказано!!!
 
то есть делаем минус шапку с того листа где код?
 
строка(1:количество позиций в обрабатываемом диапазоне)
Лень двигатель прогресса, доказано!!!
 
ROS147
не

пи

ши

те

через

строку!!!
Страницы: 1
Читают тему (гостей: 1)