Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Форумы "Планета Excel" » Вопросы по Microsoft Excel
Страницы: 1
RSS
Формула для подстановки месяцев в расчете заработной платы, Формула для подстановки месяцев в расчете заработной платы
 

Доброго всем времени суток!

Создал таблицу для расчета заработной платы. Все условия удалось реализовать, кроме следующих двух.
1. При выборе в таблице "месяц отпуска" ячейка (В12) в таблице расчетов должно срабатывать следующее правило "Если месяц выбран, т.е. ячейка В12 не пустая, то указанный в этой ячейке месяц должен повториться в колонке (F), т.е. если выбран Июль в колонке должно получиться 13 месяцев из них 2 месяца Июль. В первой строке напротив повторяющегося месяца должны рассчитаться Отпускные, во второй Остаток заработной платы, формулы которых тоже указаны в прикрепленном файле. Если же ячейка В12 пустая, то месяце 12 и во всех идет расчет зп. т.е. строка 15 в расчете останется пустой.
2. в колонке (G) подставляется количество раб дней. Если В12 пусто, то ставим рабочие дни напротив каждого месяца (формулы реализованы), а вот если В12 указан месяц то, как и в первом случае, получится 2 месяца и в первой строке напротив месяца будет надпись Отпуск!, а во втором количество рабочих дней в этом месяце (годе). В таблице "нарисовал" как должно было бы получиться при тех условиях, которые выбраны на листе.

Так же на листе оставил и выделил желтым то, что я пытался сделать для реализации вышеописанного, но так и не получилось. Может кто подскажет как эти два правила реализовать?

Изменено: Mikdad - 24 Фев 2017 14:00:43
 
Здравствуйте. Поменял формулы в столбцах F и G.
Изменено: gling - 24 Фев 2017 16:38:45
 
Огромное спасибо!  
 
Немного изменил формулы, файл поменял в сообщении #2. В столбце G прописал другую форулу, с учетом дней отпуска.
Код
=ЕСЛИОШИБКА(ЕСЛИ(СЧЁТЕСЛИ(F4:$F$16;F3);$B$13;ЕСЛИ(СЧЁТЕСЛИ($F$2:$F2;F3);ВПР(F3;$M$27:$N$77;2;ЛОЖЬ)-G2;K3+ВПР(F3;$M$27:$N$77;2;ЛОЖЬ)));"")
Изменено: gling - 26 Фев 2017 01:10:17
Страницы: 1
Читают тему (гостей: 1)